Installtion Cuda Toolkit 10.0 to Windows 10 failed

Although I was able to install Cuda 10.1 to my Windows 10 PC, it turned out what I need is NVDIA CUDA Toolkit 10.0.

I uninstalled Nsight Visual Studio etc, and tried to install NVIDIA CUDA Toolkit 10.0 using the local installer https://developer.nvidia.com/cuda-10.0-download-archive?target_os=Windows&target_arch=x86_64&target_version=10&target_type=exelocal, but it failed.

Many components, starting from NVGRAPH Development, are not installed.

Can someone give me any advice, please?

Best regards,
Kouichi

I tried everything written here (https://www.deciphertechnic.com/fix-cuda-toolkit-installation), but could not install 10.0.

“NVIDIA Installer failed”

It turned out that the installation of “Visual Studio Integration 10.0” is the one failed. Lots of other components were not installed.

Any ideas? Should I reinstall Visual Studios?

This usually works:

reload windows OS
install Visual Studio
Install CUDA

The official instructions are here:

https://docs.nvidia.com/cuda/cuda-installation-guide-microsoft-windows/index.html

Found this post (https://devtalk.nvidia.com/default/topic/1024458/cuda-setup-and-installation/nvidia-cuda-version-9-0-installer-failed/post/5337462/#5337462).

Followed the instruction there, except I used v120 instead of v140, I managed to install CUDA 10.0.

Why the hell this is so complicated???

The link you gave me is for 10.1, while I’ve been trying to install 10.0:

CUDA Toolkit Documentation v10.0.130
https://docs.nvidia.com/cuda/archive/10.0/