Seriously, what is up with Cuda 9.0 failing Visual Studio Integration

I have reinstalled Windows 10. Didn’t work.
I’ve tried unpacking the installer with 7zip and running the exe. Didn’t work.
I’ve tried uninstalling, reinstalling, all to no avail.

GTX 1060 gpu. What am I missing? There doesn’t seem to be a solution under the sun, and NVIDIA obviously doesn’t give a crap. Please any thoughts? I’ve been trying for a week straight to install this program.

Ok, this is a problem with Cuda 9.0 and Cuda 9.1. Nvidia, please escalate this issue as soon as possible. This wound has been festering for months.

Here is my fail log from my install of 9.0 on a Windows 10 Pro machine with most recent updates, after reverting the display drivers to the original ones supplied with Cuda 9.0.

The way I reverted was to install the Cuda 9.0 package with all options enabled except Visual Studio Integrations.

52.767 |     INFO: [NVI2.NVInstaller] 3004@CNVInstaller::InternalPerformInstallPackagePhases : Entering Checkpoint: Processing package phase "NsightMSITraffic". 
     52.767 |    DEBUG: [NVI2.NVInstaller] 3054@CNVInstaller::InternalPerformInstallPackagePhases : Condition "NsightMSIActionActiveAndTraffic" enabled phase "NsightMSITraffic". 
     52.767 |    ERROR: [NVI2.NVMsiPhase] 853@CNVMsiPhase::InvokePhase : COM error: -2147467259. 
     52.767 |     INFO: [NVI2.NVInstaller] 3004@CNVInstaller::InternalPerformInstallPackagePhases : Exiting Checkpoint: Processing package phase "NsightMSITraffic" ( 0 ms ). 
     52.767 |     INFO: [NVI2.NVInstaller] 2043@CNVInstaller::InternalPerformInstall : Exiting Checkpoint: Processing Package Phases in "visual_studio_integration_9.0" ( 0 ms ). 
     52.769 |    ERROR: [NVI2.NVInstaller] 2064@CNVInstaller::InternalPerformInstall : Package "visual_studio_integration_9.0" failed with error: Exception {0x80004005 - Unspecified error; File: PerformInstall.cpp; Line: 4029; Phase failure}. 
     52.769 |    ERROR: [NVI2.NVInstaller] 2123@CNVInstaller::InternalPerformInstall : Failing at package "visual_studio_integration_9.0" failed with error: Exception {0x80004005 - Unspecified error} - aborting install. 
     52.769 |     INFO: [NVI2.NVInstaller] 1919@CNVInstaller::InternalPerformInstall : Exiting Checkpoint: Processing Package "visual_studio_integration_9.0" ( 0 ms ). 
     52.769 |     INFO: [NVI2.NVInstaller] 1899@CNVInstaller::InternalPerformInstall : Exiting Checkpoint: Processing Packages ( 0 ms ). 
     52.769 |    ERROR: [NVI2.InstallThread] 54@CInstallThread::ThreadProc : Install failed - Exception {0x80004005 - Unspecified error; File: PerformInstall.cpp; Line: 4029; Phase failure} - going to fail state.

In the meantime, if you don’t need visual studio integration, disable the feature during install (custom) and everything will be fine.

Fix Method:

I got Cuda 9.0 fully installed using the very long and annoying installation procedure outlined by @oregonduckman here:

(should work also for 9.1)

The uninstallation procedure is kinda long (~30 min). Apparently recent updates to windows and/or the nvidia drivers requires that the system be completely wiped of all traces of nvidia before installing 9.0 or 9.1 currently. The uninstallation involves switching the driver for the GPU(s) to Windows Basic VGA(s), and then using Revo Uninstaller to remove every trace of Nvidia from the computer, and then deleting all “Nvidia Corporation” folders from ProgramData, Program Files, etc. Then installing regularly should “Just Work”.

Awful, takes a very long time, and makes you feel you are ripping apart the innards of your system. UNTIL NVIDIA DOES SOMETHING ABOUT THIS ERROR WHICH AFFECTS ~99% OF WINDOWS 10 USERS CURRENTLY INSTALLING CUDA FOR THE FIRST TIME, this is your best bet, sadly.

Try the method sugested by @oregonduckman and orangesherbet0 (

Step 1: Install the standard VGA driver:

  1. Bring up the Windows Device Manager. You can do that my right-clicking on the Start button and then select Device Manager.
  2. Expand the “Display Adapter” list, right-click on the GeForce card and then select “Update Driver Software”.
  3. Click “Browse my computer for driver software”.
  4. Then click the “Let me pick from a list of device drivers on my computer”.
  5. Uncheck the “Show compatible hardware” option.
  6. Under the “Manufacture” scroll to the top and select the “(Standard display type)” and then click “Next”. If you are running multiple GPUs then repeat steps #2 - #6 for each GPU.
  7. Restart Windows. This will basically load the standard VGA driver.

Step 2: Delete all Cuda reference:

  1. In Windows Services, stop all nvidia services
  2. Delete all nvidia files from C:\ProgramData, C:\Program Files, C:\Program Files(x86).
  3. Proceed with cuda installation.

This does not work. Device manager says “Windows encountered a problem installing the drivers for your device. Windows found drivers for your device but encountered an error while attempting to install them. This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)”

I tried ignoring this and proceeding but still get the same old failure:

ERROR: [NVI2.NVInstaller] 2064@CNVInstaller::InternalPerformInstall : Package "visual_studio_integration_9.2" failed with error: Exception {0x80004005 - Unspecified error; File: PerformInstall.cpp; Line: 4029; Phase failure}.

@gemcqu Many people have followed the directions and have experienced success. The original directions (which are different than the ones supplied by @pagr12) are below:

For the step where you switch display drivers, you must UNCHECK “Show Compatible Hardware”, then select “(Standard Display Types)”, then select “Microsoft Basic Display Adapter”, then select “Next”. If this does not work, try restarting to computer and repeating. If that doesn’t work, try disabling auto-driver-install, restarting the computer, and repeating. It will work, provided your system configuration is pretty standard. I’ve performed this on two different machines three times now, both from a fresh windows install, and from an old windows install.

Also, I suggest following the directions in the original post from @oregonduckman. In particular, using Revo Uninstaller makes the process more fool-proof. You don’t need to enable installer logging, however, in Step C.

Finally, people should not “copy and paste” the original directions provided by @oregonduckman. This will result in a chain of “copy and pasting”, each time the original directions becoming more and more corrupted to the point where they will not work. Simply link to the original directions as I have done.

In particular, the directions provided by @pagr12 are likely copies of the ones I posted on the original thread, applicable only for fresh installations of windows.

Using Revo Uninstaller to remove everything with “NVIDIA” in the name did not remove display drivers. (Indeed, I’m not sure that Revo Uninstaller even detected any display drivers in the first place. Regardless, Revo now lists nothing at all from Nvidia anymore.)

Meanwhile, “C:\Program Files\NVIDIA Corporation” and “C:\Program Files (x86)\NVIDIA Corporation” still exist and contain files that are still in use, like NVDisplay.Container.exe and NvTelemetryContainer.exe.

Everything that has failed, I have tried again after restarting and it still fails in the same way.

Is there official guidance on how to remove Nvidia components that persist even when none are listed in Add/Remove Programs, Revo Uninstaller, Total Uninstaller, and CCleaner?


If the below conditions are met, in this order:

Zeroth - You are following the original directions provided by @oregonduckman and not any other directions.
First - the display adapter has been switched to Microsoft Basic Display Adapter, and Windows has not attempted to replace this driver with an Nvidia driver.
Second - All Nvidia drivers and software are all uninstalled by Revo Uninstaller, including using Revo Uninstaller’s advanced checks for left-behind files and registry items, and using Revo’s capabilities to delete these items.
Third - all Nvidia Services (including Telemetry) have been stopped in Windows Services.

Then: all the nvidia folders should be delete-able. This includes C:\Program Files\NVIDIA Corporation, C:\Program Files (x86)\NVIDIA Corporation, and C:\ProgramData\NVIDIA Corporation.

If they are not, you have not successfully performed one of the above requirements, because something (Nvidia software or an Nvidia service) is still running. It is likely something you can see in Task Manager (ctrl-shift-esc) under Details or Services.

The steps provided by @oregonduckman (not @pagr12) are steps provided directly from an Nvidia employee. They will work, provided the steps are faithfully executed in every small detail (except step C), on a machine whose configuration is pretty standard. If you’re executing the steps properly, and your system encounters problems, it probably means something in your system is non-standard, and perhaps you should re-install Windows (which I end up doing about once a year anyways).

In particular, you should not be using Total Uninstaller or CCleaner, as these were not specified in the original steps provided by @oregonduckman. Also your post suggests some steps are out-of-order. For instance, the Nvidia Driver should not visible in Device Manager by the time you are using Revo; you should be able to restart your computer and boot up using the Microsoft Basic Display Adapter, without Windows trying to install Nvidia’s ever again. If Windows keeps re-installing the Nvidia driver even after you have followed the driver switching steps in Step A, try disabling Window’s driver-auto-update feature (google it).

Finally, it is very unlikely a user needs the Visual Studio plug-in unless they are developing Cuda code. If not, just disable the installation of the plug-in.

It turns out the services “NVIDIA Display Container LS” and “NVIDIA Telemetry Container” have to be disabled before %programfiles%\nvidia* can be deleted, although I did not see this in oregonduckman’s e-mail.

After doing this and deleting everything else Nvidia, the SDK installer finally worked.

Glad it worked for you. I’ll send oregonduckman an message asking him to revise his directions.