SPIDEV Disable with Device Tree Overlay

Hi there,

I am developing a SPI driver in kernel space using <linux/spi/spi.h>, but Chip Select seems is being used by SPIDEV. I am triying to use the SPI0.0 but it returns an error when I try do “insmod”, then dmesg returns me this message:

Chip Select 0 already in use.

.

I have found the Chip Select could be being used by SPIDEV, so I need disable SPIDEV in the device tree, and the best way would be to create a Device Tree Overlay with SPIDEV disable, but I am not able to make it work, I understand the device tree mechanism works, but I am not able to modify anything and make it works as I want.

Can anyone support me for SPIDEV Disable for Jetson nano 2GB?
Is there any user manual for using the device tree for jetson nano 2GB?
Is there any practical manual for device tree definition and overlay definition (for jetson nano or for linux systems are ok for me)?

Thanks in advance,
Best regards,

I have updated the device tree, and it seems I have disabled the spidev0, but I am facing with the same error.

Any idea?

You can just sudo rmmod spidev to disable it.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.