Unable to see /dev/spi* after enabling SPI1 with jetson-io.py

I am trying to enable SPI1 on my Jetson Nano 4GB developer board.
Running jetson-io works and retains the settings between reboots.
But, I have yet to see /dev/spi* created

I am running code from
https://developer.nvidia.com/jetson-nano-sd-card-image
jetson-nano-jp46-sd-card-image.zip

R32 (release), REVISION: 6.1, GCID: 27863751, BOARD: t210ref, EABI: aarch64, DATE: Mon Jul 26 19:20:30 UTC 2021

hi @user16876

Can you once try this
SPI on Jetson - Using Jetson-IO - JetsonHacks, hope this helps

Thank you

Please have below command to enable the spidev module.

sudo modprobe spidev

That is the article I was following to begin with.

sudo modprobe spidev
This worked!
I am surprised that I find no mention of this command in any of the articles I found for using SPI on Jetson.

I have to re-issue this command each time I boot. Is there a permanent solution?

This thread is related: Jetson Nano SPI and PWM not working

Yes, you can add this command to a start up script for it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.