Cannot enable SPI on Jetson Nano emmc

Hello everyone, I surfed the internet and all the forum looking for solutions to enable SPI on Jetson Nano emmc production module but I didn’t find any tidy guide that works. I made many attempts but SPI still does not work. Unfortunately I know doesn’t work on this board. I hope in your support.

Have check below topic.

I tried several times to execute the various steps in the thread you indicated but I stole several hours of work and in the end I never had physical signals coming out of the SPI on the oscilloscope. It is very strange that there are no scripts from Nvidia for a production module or a simple guide that allows you to enable a pin in a short time. So please let me know if there is something acceptable because it is not possible to lose days of work to enable one pin.

There’s jetson-io for none EMMC module to configure those PINs.
What’s your BSP version?

cat /etc/nv_tegra_release

Attached is the dtb for r32.6.1 for your reference.
nano-spi.dtb (233.6 KB)

I have EMMC module (also called production module). Is there a script or a simple way to enable SPI? I trust in you help, I’m not interested in SD or none emmc modules because on that boards Jetson-io worked fine. Thank you.

Please @ShaneCCC , is it possible to have a tested step by step procedure if there is no script an there is no other simplest ways? Can you suggest here the procedure? Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.