SSD on Jetson TX2 J120 Carrier Board from Auvidea

Hey,

I have a TX2 with the J120 carrier board from Auvidea and an 1TB M.2 PCIe 3.0 x 4 Intel SSD. I have the board flashed with Jetpack 4.3 and the Auvidea firmware for J120 from Feb 2020. The SSD shows up with lspci, but not with lsblk. I’ve tried a few of the suggestions in related posts but they all used different versions of Jetpack and J120 drivers.

Anyone with similar issues?

Thanks

I’ve got the exact same issue. My system was working with L4T 28.2.1, but I loaded Auvidea’s latest firmware (L4T 32.3.1) and now the SSD does not work. Any update on this issue?

@AuvideaSupport

@wmar5627 Did you ever figure this out? I have the exact same problem.
@AuvideaSupport Any advice. I have 3 boards that all worked fine with L4T 28.2.1, and upgrading to L4T 32.3.1 I can no longer get the SSDs to work.

Thanks.

From memory when flashing with the standard Jetpack4.3 (no Auvidea firmware), the SSD works. Unfortunately the SPI doesn’t work to read the IMU, which I needed for my project. I had to manually modify the device tree to enable the SPI.