start up program for fortran 13.8 on Mac OS X

I recently had some repairs done to my macbook air (running 10.8.5). I had had pgfortran 13.5 running. I had to reinstall xcode, and 13.5 stopped working–it looked like it wasn’t finding the right library. Okay, so I tried to install 13.8. I also created a new license key (may have been the same as the old, I didn’t check).

It looks like we no longer user lmgrd to start the licence, instead have to put PGI into the StartupItems. When I try

./PGI start

I get

Cannot open “/opt/pgi/license.log” as log file (1)
freopen: Permission denied

I tried rebooting and nothing. I also get an error message that this item has a safety issue, which might be part of the problem.

Not even sure where to start to fix it.

We are working on Xcode 5 support in our 14.* releases late in the year.

Install Xcode 4.5.2, and you should be okay.

dave

Yeah…that didn’t work. In fact now it looks like Xcode is crippled as well. Any other suggestions?

Details would be useful.

How did it ‘not work’?


What do you mean ‘Xcode is crippled’?


Here are a couple of things that are known difficulties

Goto Finder-> Applications -> Xcode
Xcode bar -> preferences -> Components
you will probably see that IOS 5.0 and 5.1 Simulators are installed,
but the ‘Command Line Tools’ is not installed. Install it.

When you try to open the installation files by double clicking, it fails
because
the file lacked some security verifier.
Instead, right click on the file -> Open, and then
say yes to ‘Open anyway’ after the same warning



If I knew what was not working, perhaps we can correct.


dave

I tried to install Xcode 4.5.2 but it would not overwrite Xcode 5.0. So I deleted the Xcode directory from the Applications folder. Probably a stupid thing to do.

I can run Xcode 4.5.2 from the downloaded .dmg file, but it does not install an Xcode directory.

With Xcode 4.5.2 launched try to run pgfortran (or pgf90 same error)

After launching lmgrd I get

pgfortran-Warning-Malformed $expr(), nonnumeric value >=
pgfortran-Warning-Malformed $expr(), nonnumeric value >=
pgfortran-Warning-Malformed $expr(), extra text: 108…
diff1.f:75:no such instruction: vzeroupper' diff1.f:84:no such instruction: vzeroupper’
diff1.f:91:no such instruction: vzeroupper' diff1.f:98:no such instruction: vzeroupper’
diff1.f:102:no such instruction: vzeroupper' diff1.f:111:no such instruction: vzeroupper’
diff1.f:118:no such instruction: vzeroupper' diff1.f:126:no such instruction: vzeroupper’
diff1.f:134:no such instruction: vzeroupper' diff1.f:138:no such instruction: vzeroupper’
diff1.f:143:no such instruction: vmovss -4(%rbp), %xmm0' diff1.f:144:no such instruction: vmovss %xmm0, -36(%rbp)’
diff1.f:146:no such instruction: vmovss %xmm0, -12(%rbp)' diff1.f:147:no such instruction: vmovss -36(%rbp), %xmm1’
diff1.f:148:no such instruction: vaddss -28(%rbp), %xmm1,%xmm1' diff1.f:149:no such instruction: vmovss %xmm0, -32(%rbp)’
diff1.f:150:no such instruction: vmovaps %xmm1, %xmm0' diff1.f:152:no such instruction: vsubss -32(%rbp), %xmm0,%xmm0’
diff1.f:153:no such instruction: `vdivss -28(%rbp), %xmm0,%xmm0’
… etc

diff1.f is a simple fortran code to take a numerical derivative of sin(x).

The failed instructions are indicative of an older Xcode than 4.5.2.
4.3 should work - not sure. Make sure you are selecting the right Xcode.

Try compiling with

% pgfortran hello.f -tp=nehalem

and see if you see the same errors. If they go away, you can workaround the
problem by creating/editing a siterc file in your pgi bin directory, with the
line

set PREOPTIONS=-tp=nehalem;

(the semicolon at the end is important!)

regards,
dave

I will try Xcode 4.3. Do I want 4.3 or 4.3.3 which is available?

By the way, those all are labled “Xcode 4.3… for Lion” and I have Mountain Lion. Still try to install?

UPDATE–it wants Lion and will not install under Mountain Lion. I can’t find a version of Xcode 4.3 for Mountain Lion.

Prior to that (slow download, bad wifi at work) I tried the switch

pgfortran diff1.f -tp=nehalem
pgfortran-Warning-Malformed $expr(), nonnumeric value >=
pgfortran-Warning-Malformed $expr(), nonnumeric value >=
pgfortran-Warning-Malformed $expr(), extra text: 108…
ld: warning: directory not found for option ‘-L/usr/lib/gcc/i686-apple-darwin10/4.2.1/x86_64’
ld: warning: directory not found for option ‘-L/usr/lib/gcc/i686-apple-darwin10/4.2.1’
ld: library not found for -lgcc

by the way, I ran lmgrd first—should I be doing that? Not clear.

Thanks

Okay, I resolved the issue. The key was installing Xcode 4.5.2, and then going back to PG Fortran 13.5, which I still had–I just had to change the path in my .bash_profile.

Right now, it appears to work as before, which is just fine for me.