Startx fails on Fedora Linux 36 and akmod-nvidia-340

nvidia-bug-report.log.gz (82.0 KB)

startx – -logverbose 6

According to the logs, the Xserver is starting fine.

Thanks for reading the log for me! What I have on the screen (following a boot) is ‘Oh no! Something went wrong’ and ‘A problem occurred and the system can’t recover. Please contact your system administrator.’ This text is just after the NVIDIA splash screen.

I upgraded this system from the linux graphics driver to NVIDIA yesterday and it all worked very well. On boot today I get the message above.

Ok, that error message helps. The Xserver can’t find the GLX module, there’s a path missing.
Please add to your /etc/X11/xorg.conf

Section "Files"
  ModulePath "/usr/lib64/nvidia-340xx/xorg, /usr/lib64/xorg/modules"

That worked to a point, thanks! Following the edit I updated the files section to…

Section “Files”
ModulePath “/usr/lib64/nvidia-340xx/xorg”
ModulePath “/usr/lib64/xorg/modules”

Now I have the GUI on two screens, one of them is showing pink snow and the content seems to be inverted (color) in some way. This may be another issue, happy to start a new post.

All the best Jonathan

nvidia-bug-report.log.gz (81.3 KB)

You shouldn’t need to set the module path as it’s already set in /etc/X11/xorg.conf.d/99-nvidia.conf

This path doesn’t exist /usr/lib64/nvidia-340xx/xorg


sudo dnf reinstall xorg-x11-drv-nvidia-340xx


sudo dnf reinstall /etc/X11/xorg.conf.d/99-nvidia.conf

The Xserver didn’t like the space between the paths, sorry.
Which monitor show the pink screen, the HP LP2065? It’s detected as “External LVDS” which is rather odd, to which port is it connected?

@leigh123linux if the path /usr/lib64/nvidia-340xx/xorg doesn’t exist, why does the Xserver find the module there?

(II) Loading /usr/lib64/nvidia-340xx/xorg/

I didn’t make it up, I looked at the rpm.
The package only installed
which doesn’t contain the module path. /etc/X11/xorg.conf.d shouldn’t be used by distro packages, it’s for user purposes.

@generix Your right.

Guy’s thanks for your time on this.

I ran in the reinstall xorg-x11-drv-nvidia-340xx and that worked well but no change at the display level.

Rebooting the PC gets a working LP2065 and an off color HP1955.
The HP1955 is connected to the DVI port on the graphics card

I hope this helps, all the best Jonathan

Did you already try to connect the DVI cable to the LP2065 to rule out a defective cable/connector?

I checked the plugs and lugs, it did not seem to make any difference.

At one point I connected a laptop to the display and that worked, when I re attached to the PC, its also working.

For full disclosure, I messed around with the plugs and cables a lot before I connected the Laptop, I had the idea that the fault was at/in the screen.

One test that I would like to rerun is a test on all of the ports on the card - one at a time, just in case. But right now its all working, both screens are running on DV ports look just fine.

thanks for your help, all the best Jonathan
nvidia-bug-report.log.gz (108.7 KB)