Steam won't launch with new 450.57 driver

Updated my pop os with new nvidia driver and now steam doesn’t open. As far as I found out it’s because the new drivers rolled out without 32 bit support which (maybe). Is there any workaround or do I have to roll back to 440? Please help.

Either roll back to 440 or apply the solution mentioned here. That is due to PPA that is maintained by Canonical lacks 32 bit portion for 20.04 base as of now. It works , i personally tried.

I’m so sorry to be like this, but I don’t really understand how to do this:

Yes, that’s it, just change focal to eoan, then of course after that do an apt-update, and then apt install nvidia-driver-450 <…other nvidia-450 packages>.

And the terminal line that he provided did not do anything for me. Terminal output from that line:

E: Package ‘libnvidia-compute-450:i386’ has no installation candidate
E: Package ‘libnvidia-decode-450:i386’ has no installation candidate
E: Package ‘libnvidia-gl-450:i386’ has no installation candidate
E: Package ‘libnvidia-ifr1-450:i386’ has no installation candidate
E: Package ‘libnvidia-decode-450:i386’ has no installation candidate
E: Package ‘libnvidia-compute-450:i386’ has no installation candidate

For you convenience I’ll provide the line as well:

sudo apt install nvidia-driver-450 libnvidia-gl-450 libnvidia-compute-450 libnvidia-extra-450 nvidia-compute-utils-450 libnvidia-compute-450:i386 libnvidia-decode-450:i386 libnvidia-ifr1-450 libnvidia-fbc1-450 libnvidia-gl-450:i386 libnvidia-ifr1-450:i386 libnvidia-decode-450:i386 libnvidia-compute-450:i386

No need to be sorry.

Head to /etc/apt/sources.list.d

Right click to anywhere inside that folder , choose the option that says open directory with admin rights.

Then go into graphics drivers ppa entry ( assuming you used that ppa ) , change :

deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu focal main

deb-src http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu focal main

To:

deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu eoan main

deb-src http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu eoan main

Then you can apply what he said as installing missing stuff.

That is just a workaround and and that would be better to revert your ppa source to original form after job is done.

I think I’ve done what you’ve told me, but when I paste in that line I get this:

xx-pc:~$ sudo apt install nvidia-driver-450 libnvidia-gl-450 libnvidia-compute-450 libnvidia-extra-450 nvidia-compute-utils-450 libnvidia-compute-450:i386 libnvidia-decode-450:i386 libnvidia-ifr1-450 libnvidia-fbc1-450 libnvidia-gl-450:i386 libnvidia-ifr1-450:i386 libnvidia-decode-450:i386 libnvidia-compute-450:i386
Reading package lists… Done
Building dependency tree
Reading state information… Done
libnvidia-compute-450 is already the newest version (450.57-0ubuntu0~0.20.04.2).
libnvidia-compute-450 set to manually installed.
libnvidia-extra-450 is already the newest version (450.57-0ubuntu0~0.20.04.2).
libnvidia-extra-450 set to manually installed.
libnvidia-fbc1-450 is already the newest version (450.57-0ubuntu0~0.20.04.2).
libnvidia-fbc1-450 set to manually installed.
libnvidia-gl-450 is already the newest version (450.57-0ubuntu0~0.20.04.2).
libnvidia-gl-450 set to manually installed.
libnvidia-ifr1-450 is already the newest version (450.57-0ubuntu0~0.20.04.2).
libnvidia-ifr1-450 set to manually installed.
nvidia-compute-utils-450 is already the newest version (450.57-0ubuntu0~0.20.04.2).
nvidia-compute-utils-450 set to manually installed.
nvidia-driver-450 is already the newest version (450.57-0ubuntu0~0.20.04.2).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
libnvidia-compute-450 : Breaks: libnvidia-compute-450:i386 (!= 450.57-0ubuntu0~0.20.04.2) but 450.57-0ubuntu0~0.19.10.2 is to be installed
libnvidia-compute-450:i386 : Breaks: libnvidia-compute-450 (!= 450.57-0ubuntu0~0.19.10.2) but 450.57-0ubuntu0~0.20.04.2 is to be installed
libnvidia-gl-450 : Breaks: libnvidia-gl-450:i386 (!= 450.57-0ubuntu0~0.20.04.2) but 450.57-0ubuntu0~0.19.10.2 is to be installed
libnvidia-gl-450:i386 : Breaks: libnvidia-gl-450 (!= 450.57-0ubuntu0~0.19.10.2) but 450.57-0ubuntu0~0.20.04.2 is to be installed
libnvidia-ifr1-450 : Breaks: libnvidia-ifr1-450:i386 (!= 450.57-0ubuntu0~0.20.04.2) but 450.57-0ubuntu0~0.19.10.2 is to be installed
libnvidia-ifr1-450:i386 : Breaks: libnvidia-ifr1-450 (!= 450.57-0ubuntu0~0.19.10.2) but 450.57-0ubuntu0~0.20.04.2 is to be installed
nvidia-driver-450 : Depends: libnvidia-decode-450 (= 450.57-0ubuntu0~0.20.04.2) but it is not going to be installed
Depends: libnvidia-encode-450 (= 450.57-0ubuntu0~0.20.04.2) but it is not going to be installed
Recommends: nvidia-prime (>= 0.8)
Recommends: libnvidia-compute-450:i386 (= 450.57-0ubuntu0~0.20.04.2)
Recommends: libnvidia-decode-450:i386 (= 450.57-0ubuntu0~0.20.04.2)
Recommends: libnvidia-encode-450:i386 (= 450.57-0ubuntu0~0.20.04.2)
Recommends: libnvidia-ifr1-450:i386 (= 450.57-0ubuntu0~0.20.04.2)
Recommends: libnvidia-fbc1-450:i386 (= 450.57-0ubuntu0~0.20.04.2)
Recommends: libnvidia-gl-450:i386 (= 450.57-0ubuntu0~0.20.04.2)
E: Unable to correct problems, you have held broken packages.

Any recommendations?

Did you do a sudo apt-get update to refresh the cache?

After doing it , try again.

Yes I have, doesn’t seem to work tho, still get the same outcome. Must of done something wrong I guess.

Either remove all 450 driver related stuff and try again or just simply roll back to 440 and wait for a proper fix then.

That issue happening there is entirely a stupidity from Canonical ( Ubuntu base )

in /etc/apt/sources.list.d this folder I have 2 files called “graphics drivers ppa focal” one is .list the other one is focal.list.save I changed the one without the .save.
Also was I supposed to change the 2nd line as well in the .list file which starts with a # deb-src ?

Yes , you need to change one that starts with deb as well.