Streaming Client extension [omni.kit.livestream.native] not working since 2022.2.1

Since the last release (2022.2.1), trying to connect using the Streaming Client causes a crash.
I’ve tried running both ./ or through scripting with ./ and the same happens, as soon as the Streaming Client tries to establish connection, a crash detected message can be read in the terminal and it just closes.
Exactly the same procedure worked until 2022.2.0

Hi - Someone from our team will review this issue and respond.

1 Like

@christianbarcelo Please share some additional info.

  • Is both Isaac Sim and the Streaming Client on the same network?
  • Are you running Isaac Sim from the container or the Launcher?
  • Please share your Isaac Sim log file.
  • What is your docker run command?
  • Isaac Sim and the Streaming Client are running in the same computer
  • I’m running from the container
  • I’m sharing the output of The line creash detected is exactly when Streaming Client tries to connect.
  • I’ve tried two methods:
    • → Then Streaming Client from the host
    • ./ <my_script> (The script brings up a Simulation App and the omni.kit.livestream.native extension) → Then run the Streaming Client from the host. Important to say this script works correctly with the previous version

isaac_sim.log (51.7 KB)

Does your docker run command look like this?

docker run --name isaac-sim --entrypoint bash -it --gpus all -e “ACCEPT_EULA=Y” --rm --network=host
-v ~/docker/isaac-sim/kit/cache/Kit:/isaac-sim/kit/cache/Kit:rw
-v ~/docker/isaac-sim/cache/ov:/root/.cache/ov:rw
-v ~/docker/isaac-sim/cache/pip:/root/.cache/pip:rw
-v ~/docker/isaac-sim/cache/glcache:/root/.cache/nvidia/GLCache:rw
-v ~/docker/isaac-sim/cache/computecache:/root/.nv/ComputeCache:rw
-v ~/docker/isaac-sim/logs:/root/.nvidia-omniverse/logs:rw
-v ~/docker/isaac-sim/data:/root/.local/share/ov/data:rw
-v ~/docker/isaac-sim/documents:/root/Documents:rw

Try update to the latest driver below:

My docker run used to look as the documentation says (or at least used to say, haven’t checked it back now) but I’ve turned to use your suggestion, same issue.

Then I updated to the exact same driver version you suggested, and I happened to have the same issue.
Let me attach the logs, where the version of the driver is shown in the traceback.
seg_fault_streaming_client_new_driver.log (53.4 KB)

Sorry, I just noticed that you are using a 3050 Ti with 4GB of VRAM. This does not meet the minimum requirement to run Isaac Sim. See 1. Isaac Sim Requirements — Omniverse Robotics documentation.

That’s a fair point, tho I had a hope it would work as the previous version at least.
Seems I’m gonna have to use a different computer for this.

Edit: Using Isaac Sim non-headless (through Omniverse Launcher) works just fine even with a low resources computer (RTX 3050), so I still think there’s something odd going on specifically with the Streaming Client’s extension.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.