Stuck in NVIDIA Logo - Jetson Nano Sub Kit Not Booting after Partition Deletion


I have been facing some issues with my Jetson Nano Developers Kit. Initially, I had a 128GB SD card, but it only showed me around 28GB of storage, spread across two disks - a 16GB eMMC in the carrier board and the rest from my SD card. After using “lsblk,” I found that my 128GB disk had 14 partitions, and only one of them was mounted, which meant I was only getting about 12GB of space from my 128GB disk. To resolve this issue, I decided to delete the partitions and leave only one partition with the remaining 116GB, hoping that it would solve my space problems.

However, when I tried to install a Python library (TensorFlow), I noticed that it was getting installed in the 16GB eMMC instead of the SD card. I tried moving the Python path and setting a TMPDIR, but it still consumed space from the eMMC. I then thought of moving all the contents from the eMMC to the second partition (116GB), hoping to stop my space problems. But when I used rsync to move the contents, the space available in the 16GB eMMC went to 0 bytes, and the space in the second partition did not change. I left it for a while and then faced a power outage.

After plugging in my Jetson Nano Developers Kit, it got stuck on the Nvidia logo and didn’t boot. I tried flashing the SD card image again on my 128GB SD card, but the boot was still not happening, and the screen was frozen. I researched and found tutorials on the Nvidia forum suggesting that I flash the SDK using SDKManger. However, I realized that I had a Youyeetoo Jetson Nano Sub Kit with an SD slot, which is an alternative to Jetson Nano B01 and is based on the Nvidia Jetson Nano SOM onboard with 16GB eMMC (fan cooling).

I found a tutorial on how to boot from the SD card (Firmware update | youyeetoo wiki), but it is not entirely clear to me. I think that the system was booting from the eMMC, and the SD card was just acting as media storage. I am currently installing Ubuntu on an old spare computer, so I have not tried the tutorial yet. My question is, should I follow this tutorial, and is it up to date?

Furthermore, I am facing an issue where Python libraries are only downloading in the booting disk, and I would like to resolve this problem. Can you please suggest any other solutions to get my Jetson Nano Developers Kit booting again, and how I can fix my space issue with Python libraries?

Thank you for your help.

Regarding partitions which are not mounted, consider that a Jetson (and most embedded systems) do not have a BIOS. For eMMC models the equivalent of the BIOS, plus boot content, is in those partitions. On SD card models, that content is in the QSPI memory of the module. Deleting this either deletes the boot content or the equivalent of erasing the BIOS (an exception might be that if you have a model supporting redundant boot backup, then the alternate content might delete ok). You can clone and save the rootfs if you wish, but you’ll need to reflash to get the non-rootfs content back.

Instructions differ depending on whether this is NVIDIA’s dev kit versus a third party carrier board. Note that dev kits do not have eMMC, and you wouldn’t see the QSPI partitions. I suspect this is a third party carrier board with a commercial eMMC model of module. Any added instruction would depend on the model (typically provided by the manufacturer of the carrier board). It is important to know exactly which model you are referring to. Is it really eMMC or is it just an SD card? I think it is likely eMMC.

Hi patrickVeronics,

Yes, you are using a custom board from Youyeetoo. The Jetson Nano devkit from NVIDIA would not come with eMMC and SD Card slot at the same time.

Please get the BSP package from your vendor first.
Then, make sure you could boot up successfully w/o SD card.
Last, insert and flash into SD card and mount it as rootfs.

Are you using standalone Ubuntu 18.04 as your host PC?

and what’s the Jetpack version in use?

Dear linuxdev and KevinFFF,

Thank you for your responses and suggestions. I am pleased to inform you that I was able to install Ubuntu 18.04 on a spare laptop and successfully flash Jetpack 4.6.1 to the Jetson Nano. The device now boots perfectly from the eMMC without the SD card inserted.

However, I am still facing the issue of limited storage space. I have the Jetpack 4.6.1 flashed onto an SD card, but I am hesitant to mount it as I only had around 12-14GB of space on the 128GB card on my first boot.

I did the flash on the host PC but I am curious, does the flash on the SD card need to happen on a host PC or on the Nano itself?
Will the device boot from the SD card upon reboot if I mount it into rootfs?
Also, I believe the issue of the 128GB not showing will be solved by resizing the root partition, as mentioned in the documentation provided. Is it necessary to move anything to/from the eMMC?

Thank you for your help.


This requires some explanations:

  1. Kevin already told, you are using a custom board. That sdcard is added by the board vendor on the custom carrier board.

  2. I don’t know which jetpack4.6.1 you are talking about. The sdkmanager provides a pure jetpack4.6.1. The board vendor may use our pure jp4.6.1 to make their own BSP.
    Only the BSP provided by the board vendor can enable the sdcard slot. As I already said in (1), this slot is added by them. Pure jp4.6.1 won’t know it and won’t enable it.

  3. Thus, based on above. You need to tell us whether you are using their BSP or pure jp4.6.1 first.

If you are using pure jp4.6.1, then for your question:

I did the flash on the host PC but I am curious, does the flash on the SD card need to happen on a host PC or on the Nano itself?

None of them would matter. As that sdcard won’t get read on jetson nano with pure jp4.6.1.

Hi WayneWWW,

I believe I have the vendor’s BSP, because the SD card is indeed recognized when inserted in the slot. I flashed using SDK Manager but I had to modify the device tree for the SD card to be readble per the turtorial of the vendor.


just wanted to let you know that the issue has been solved. I was not formatting my SD card as an ext4, which is what was causing the errors. I formatted it, unmounted it, edited the extlinux.conf file, and rebooted. Now I have 128 GB mounted on “/” and 15 GB of extra space of the eMMC.

Thank you for your help.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.