Stuck on install of JetPack 2.0 for TK1

When prompted to enter IP address and login information I receive the error message,

Return Code:1
Error:Cannot connect to device with given information.
Please check you input and try again.

Has anyone else run into this? Thanks

I do not personally have JetPack because I use Fedora instead of Ubuntu, but a short checklist would help.

During flash, the Jetson is in recovery mode. Internet is irrelevant when in recovery mode. The connection information thus means the Jetson had to be running…if flash occurred, then connection becomes relevant after reboot of the Jetson. Was the Jetson on, and if flashed, had it been rebooted?

Second, address information for Jetson using default methods uses a DHCP server to give the Jetson an address. This means a DHCP server had to be available. The choices are that either the host is configured to provide the DHCP to Jetson, or else an outside DHCP server had to respond, such as a router. I would typically expect that this be provided by the host PC during flash, and JetPack can set this up. However, the DHCP served by the host means that once setup is completed on the host the Jetson either needs reboot or manual restart of networking to tell it to ask for an address. I assume something gave a hint of the address during JetPack install if the PC was used for DHCP serving. If not, then your router would have that information (perhaps via a web interface to see, or from a Jetson console using ifconfig). In any case, a reboot of the Jetson can double check to be sure the address is correct. Ping of the address can also verify existence.

During an actual login the default on all Ubuntu is user “ubuntu” with pass “ubuntu”. I doubt this is the issue though, as the error message would have likely been different.

After a reboot of Jetson, can you ping the address? Are you providing DHCP from the host or from a router?

It came when the installer tries to connect via ssh to upload to my device and I entered the wrong ip.

Do you know the IP?

When i entered the right ip ubuntu ubuntu it works. Have you logged in before and the RSA key might need to be deleted?

It will also retry, as far as I remember, for quite a while.

I had no wifi on the device and no switch or router where i have to USB connect to my linux host, so I did the USB flash then down the stairs plug in and then up again, continue and the installer waited.

I had an odd bit where the VisualWorks was played over before the flash, then the flash and then down again to plug into the router.

If your router has a webpage it tells you there as tegra-ubuntu what IP the device is connected as.

But linuxdev already covered that bit.

I looked up the IP for the device in the Network setting and I believe it was correct. When I checked the setting it also looked like it was automatically being assigned its IP by DHCP. I had both the host and the target (TK1) plugged directly into my router via LAN cables. I will try pulling up the Routers GUI and double check that I have the right IP. Is there anything I need to do to set up the SSH between the host and target?

For SSH, see the Target Setup section of http://docs.nvidia.com/jetpack-l4t/index.html#developertools/mobile/jetpack/jetpack_l4t/2.0/jetpack_l4t_install.htm

Setting up the SSH to target by entering IP, username and password is where I run into the issue. I believe all the information I input to be correct, yet I still get an error message and am unable to continue with the process to flash the Jetson TK1.

Can you ssh ubuntu@tegra-ubuntu?

If you have connected before and reflashed, your encryption key in .ssh in your home directory might be different.

You need to delete the key for the jetson ip.

https://www.digitalocean.com/community/tutorials/understanding-the-ssh-encryption-and-connection-process

Last night I reinstalled Ubuntu on my host PC and re-flashed my Jetson TK1 to original factory software. Both booted and looked stable and I will try to re install Jetpack tonight. If unsucessful I will post screenshots.

When you found this error message, can you please test if you can ssh connect from host to Jetson TK1 with the IP/username/password you provided in the dialog box?

Success!! The only thing I did differently was connect to the Jetson TK1 prior to flash by the command in the terminal ‘ssh ubuntu@tegra-ubuntu’. Thanks for everyones help

Can you login to your router(*) and see what IP address has been assigned ?

  • At a guess, possibly 192.168.0.1, or type “route” from a connected linux device and see what the gateway IP address is.

I have the same problem, but I am able to manually ssh ubuntu@tegra-ubuntu or ubuntu@theipaddress.

Anyone has found another solution ? Is there any way to see the logs of what JetPack is trying to do what it is stuck on ?

EDIT: I’ve identified the problem : I was running the installer with sudo because it didn’t work without it, the screen to give IP and username didn’t appear and the program ran directly into finish. I’ve now done a nasty

chmod -R 775 *

inside my JetPack folder and now the installer works without sudo and now the installer doesn’t get stuck on the connection page.