Sudo is not working when I reflash drive agx

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04


I tried to reflash the drive AGX just xavier B and the flashing was successful.
After flashing, I tried to use sudo apt update or sudo installation and I am getting the following error:

Welcome to Ubuntu 18.04.5 LTS (GNU/Linux 4.14.193-rt92-tegra aarch64)

To restore this content, you can run the ‘unminimize’ command.
Last login: Thu Oct 6 18:54:12 2022 from
To run a command as administrator (user “root”), use “sudo ”.
See “man sudo_root” for details.

nvidia@tegra-ubuntu:~$ ls
nvidia@tegra-ubuntu:~$ sudo apt update
sudo: /usr/bin/sudo must be owned by uid 0 and have the setuid bit set

I was not able to log in as root as well.
can you please help me with this issue?

Thank you

Hi @user158496
No other developer has ever raised the issue.
Which DRIVE OS version did Xavier A and B have before flashing? Which DRIVE OS version was Xavier B reflashed? Could you try flashing both Xaviers? Thanks.

I am reflashing it everytime and never faced this issue before. Drive OS 5.2.6 is the one I used to flash.

Please try if reflashing both Xaviers helps. Thanks.