Xavier A+B wont flash

Software Version [I’m not sure]
Target Operating System[Linux]
Hardware Platform[NVIDIA DRIVE™ AGX Xavier DevKit (E3550)]
SDK Manager Version[]
Host Machine Version[native Ubuntu 18.04]

I have been having issues with my Drive AGX where I can’t connect it to the ethernet for months and I have been able to use it. I decided to completely start over and reinstall ubuntu on the host computer and try downloading the SDK Manger again and trying to reflash the AGX hoping that this would fix my problem. Last week I thought that I was able to reflash the AGX but Xavier doesn’t seem to boot up. The light by the debugging port is on and the fans for the motherboard are also on but there isn’t any signal coming from the HDMI ports. I tried reflashing the AGX a couple of time again through the GUI and the command line (probably doesn’t make a difference) and the AGX is still not booting up. I think it might be in some kind of recovery mode but I’m not sure how to get it back into normal mode. Also, I don’t think the AGX is reflashing correctly. The SDK manager says that Flash for Xavier A+B was Skipped. Any advice for this issue is greatly appreciated. Like I said, it has been over a month since we haven’t been able to use this computer.

Output from SDK manager in the latest flashing attempt:
Authenticating with NVIDIA server…
Login succeeded.
Loading user information…
User information loaded successfully.
Loading server data…
Server data loaded successfully.
Session initialized…

  - CUDA on Host: Up-to-date
  - CUDA Cross-Compile for Linux: Up-to-date
  - cuDNN x86: Up-to-date
  - cuDNN Cross-Compile for Linux: Up-to-date
  - TensorRT x86: Up-to-date
  - TensorRT Cross-Compile for Linux: Up-to-date
  - CMAKE build utility: Up-to-date
  - NVIDIA Nsight Graphics: Installed
  - NVIDIA Nsight Systems: Installed
  - GNU Toolchains: Up-to-date
  - DRIVE Foundation Packages: Up-to-date
  - DRIVE Foundation OSS Packages: Up-to-date
  - P3479 Specific Package: Up-to-date
  - E3550 Specific Package: Up-to-date
  - Flash Tools: Up-to-date
  - OSS Packages: Up-to-date
  - OSS Source Packages: Up-to-date
  - NV Packages: Up-to-date
  - File System: Up-to-date
  - File System Tools: Up-to-date
  - DRIVE OS Linux SDK Documentation: Up-to-date
  - Flash Xavier A+B in parallel: Installed
  - Flash Xavier A: Skipped
  - Flash Xavier B: Skipped

  ===== Installation completed successfully - Total 24 components =====
  ===== 3 succeeded, 0 failed, 19 up-to-date, 2 skipped =====

Thank you,

Hi @pola5392,

Were you installing NVIDIA DRIVE™ OS 5.2.0? Please check below in its DRIVE OS Release Notes. The Ubuntu desktop system isn’t part of default installation anymore. Thanks.


1 Like

Hello @VickNV ,
Thank you for responding. I did try installing the NVIDIA DRIVE OS 5.2.0 as well as DRIVE SOFTWARE 10.0. I do not understand what the difference between these two systems are and which I should install.

If I do install the NVIDIA DRIVE 5.2.0 and I would like to install ubuntu desktop, where do I put in this apt command? Do I do this directly into the AGX? There isn’t a terminal coming from the HDMI signals either.

Thank you,

Please take a look at Accessing the SoC from UART. After you can access via UART, you can also enable ssh acccess by following DRIVE OS Linux SSH Server. Thanks!

Great, I will try this and follow up if this solved my problem.

1 Like

Hello Vick,
I was able to access the SoC from UART with the documentation that you referenced to me. I think that I will mark your response as the solution to my problem but now I am back to my original problem of not being able to connect to the internet. I am unable to make upgrades and download anything using apt. I will open a new forum with further detail. Thank you for your help.