Suspend / Resume fails on Fedora 30 using Lenovo P52 with Quadro P1000

I’m using Fedora 30 on a Lenovo ThinkPad P52 with a Quadro P1000. I’m not using hybrid graphics but set the bios to just use the dedicated graphics. Everything seems to work fine except resuming. Using the open source nouveau driver the screen stays black and I can not get to any logs. With the Nvidia driver 430.14 the screen also stays black on resume but I can ssh into the machine and pull logs. The logs show:

[  433.818813] nvidia-modeset: ERROR: GPU:0: Failed detecting connected display devices
[  433.818841] nvidia-modeset: WARNING: GPU:0: Failure processing EDID for display device CMN (DP-2).
[  433.827901] nvidia-modeset: WARNING: GPU:0: Unable to read EDID for display device CMN (DP-2)
[  433.827904] nvidia-modeset: ERROR: GPU:0: Failure reading maximum pixel clock value for display device CMN (DP-2).
[  433.827996] BUG: unable to handle kernel NULL pointer dereference at 0000000000000038

nvidia-bug-report.log.gz (977 KB)
acpidump.txt (1.24 MB)

And your using Gnome wayland?

‘acpi_osi=!’ can be used in combination with single or
multiple ‘acpi_osi=“string1”’ to support specific OS
vendor string(s). Note that such command can only
affect the default state of the OS vendor strings, thus
it cannot affect the default state of the feature group
strings and the current state of the OS vendor strings,
specifying it multiple times through kernel command line
is meaningless. This command is useful when one do not
care about the state of the feature group strings which
should be controlled by the OSPM.
Examples:
1. ‘acpi_osi=! acpi_osi=“Windows 2000”’ is equivalent
to ‘acpi_osi=“Windows 2000” acpi_osi=!’, they all
can make ‘_OSI(“Windows 2000”)’ TRUE.

https://github.com/Bumblebee-Project/Bumblebee/issues/764

YOUR Specs:
Linux Certification - ThinkPad P52 (20MAZ458CN)
ThinkPad P52 (20MAZ458CN) for Linux certification
Device Description
Processor Intel Core i7-8850H CPU @ 2.60GHz
Memory 16GB
Hard Disk Device TOSHIBA NVMe 256GB SSD
LID (Display) 15.6" 1920x1080 LED
Graphics card Intel UHD Graphics 630
NV Quadro P1000
Battery Li-Polymer
Chipset Coffee Lake
Ethernet Intel Ethernet Connection I219-LM
Wireless Intel Wireless-AC 9560
Audio Realtek ALC285 Codec
USB 3x USB 3.0

Did you check if suspend/resume works when using Windows, to rule out a hw issue?

I just tested Windows 10 from an USB stick and it worked just fine.

I also did a few tests with acpi_osi but the error in the logs was the same.

Please check with an ealier driver, e.g. v390.
Also, please run
sudo acpidump >acpidump.txt
and attach the output file.

I attached the acpidump to my initial post now. I’ll try to install the older driver tomorrow.

Using driver 390.116 the resume works just fine :-)
The screen brightness buttons do not work however.

So it’s a driver bug. Please try driver 410 and 418 to find out when this broke.
The brightness keys were fixed after 390, but that driver already has that fix but disabled. Can be enabled by loading the nvidia kernel module with option
NVreg_EnableBacklightHandler=1

I’m getting a bit of strange suspend reactions now. In a first test 410.104 and 418.74 did not finish suspend when using the UI. After I did a hard shutdown by pressing the power button for 10s and then rebooted it looked like it resumed to the state before. So for some reason it looks like it did a suspend to disk but did not finish. Using

systemctl suspend

things worked just fine though with at least 418.74.

With 418.74 the brightness keys also work again. With 410.104 they did not.

So except some odd UI suspend behavior 418.74 looks good.

I can also test 430.09.

You have hybrid suspend enabled, that might have interfered.
If possible, also test 430.09 and then send your results and nvidia-bug-report.log to linux-bugs[at]nvidia.com to have it fixed.

Using 430.09 suspend works normal again (bit surprising to me that the NVidia driver has such an effect) but the resume fails in the same way as with 430.14. Can I get other versions to test somewhere?
nvidia-bug-report-430_09.log.gz (1010 KB)

Those were pretty much all available drivers, nothing inbetween 418.74 and 430.09. So this broke with v430.
Driver archive:
https://http.download.nvidia.com/XFree86/Linux-x86_64/

Ok, thanks. I mailed the logs now.

Am I supposed to get an reply from nvidia-bug-report.log to linux-bugs[at]nvidia.com or can I track my issue somewhere else then on this page? So far I have not seen any reaction, which this forum worked very fast.

Most bugs are silently fixed, some show up in the changelog, you can only test every new driver that gets released and report back if it works/doesn’t work.

With 435.21 suspend and resume works on Fedora 30 for me again.