symbol lookup error with cuvidGetDecodeStatus

I have compiled the samples/AppDecode/AppDec in video codec sdk.

Everything is fine when compiling.

but when running the program,

./AppDec -i ~/facenet-tensorRT/video_first_1_960.h264
GPU in use: GeForce GTX 1080
Decode with demuxing.
[INFO ][17:34:17] Media format: raw H.264 video (h264)
Session Initialization Time: 26 ms
./AppDec: symbol lookup error: ./AppDec: undefined symbol: cuvidGetDecodeStatus

there is a symbol lookup error.

And I tried ldd to find the shared libraries linked to. =>  (0x00007ffd691fb000) => /usr/lib/x86_64-linux-gnu/ (0x00007fa81717d000) => /usr/lib/nvidia-384/ (0x00007fa816d2e000) => /home/tumh/ffmpeg_build/lib/ (0x00007fa81567e000) => /home/tumh/ffmpeg_build/lib/ (0x00007fa815406000) => /home/tumh/ffmpeg_build/lib/ (0x00007fa814fb7000) => /usr/lib/x86_64-linux-gnu/ (0x00007fa814c35000) => /lib/x86_64-linux-gnu/ (0x00007fa814a1f000) => /lib/x86_64-linux-gnu/ (0x00007fa814654000) => /lib/x86_64-linux-gnu/ (0x00007fa81434b000) => /lib/x86_64-linux-gnu/ (0x00007fa814147000) => /lib/x86_64-linux-gnu/ (0x00007fa813f29000) => /lib/x86_64-linux-gnu/ (0x00007fa813d21000) => /usr/lib/nvidia-384/ (0x00007fa813acf000) => /usr/lib/nvidia-384/ (0x00007fa81382a000) => /home/tumh/ffmpeg_build/lib/ (0x00007fa81360d000) => /lib/x86_64-linux-gnu/ (0x00007fa8133eb000) => /lib/x86_64-linux-gnu/ (0x00007fa8131d0000) => /lib/x86_64-linux-gnu/ (0x00007fa812fc0000)
/lib64/ (0x000055c109d52000) => /usr/lib/nvidia-384/ (0x00007fa812d8f000) => /usr/lib/nvidia-384/ (0x00007fa812ac1000) => /usr/lib/x86_64-linux-gnu/ (0x00007fa812787000) => /usr/lib/x86_64-linux-gnu/ (0x00007fa812574000) => /usr/lib/x86_64-linux-gnu/ (0x00007fa812352000) => /usr/lib/x86_64-linux-gnu/ (0x00007fa81214e000) => /usr/lib/x86_64-linux-gnu/ (0x00007fa811f47000)

you can see that the executable links to /usr/lib/nvidia-384/, but there is one located in NvCodec/Lib/linux/stubs/x86_64/

What is the difference between these two

it seems that the possible solution is to link NvCodec/Lib/linux/stubs/x86_64/, not the driver’s one.

However, I tried to add the path to LD_LIBRARY_PATH, but it does not work. it still link to the driver lib.

Any advice?

Environment: cuda-8.0


Seems like you’re using linux as the OS. What’s your driver version and the exact OS version you are using?

Ryan Park


My mistake, I see that your driver version is R384.

Please upgrade to R396 drivers. The said API is not supported on R384 drivers.

Stub libraries ( and have been included as part of the SDK package, in order to aid development of applications on systems where the NVIDIA driver has not been installed. The sample applications in the SDK will link against these stub libraries as part of the build process. However, users need to ensure that the stub libraries are not referenced when running the sample applications. A driver compatible with this SDK needs to be installed in order for the sample applications to work correctly.

Ryan Park