TAO BodyPoseNet - Did you run docker login?

• Hardware (NVIDIA GeForce RTX 2060 SUPER)
• Network Type (BodyPoseNet)
• TAO Toolkit Version (3.22.05)

Hello, I am currently trying to use BodyPoseNet but every time I run !tao bpnetin jupyter notebook I have the following error:
Traceback (most recent call last):

File “/home/mm/miniconda3/envs/tao_env_3.6/bin/tao”, line 8, in
sys.exit(main())
File “/home/mm/miniconda3/envs/tao_env_3.6/lib/python3.6/site-packages/tlt/entrypoint/entrypoint.py”, line 115, in main
args[1:]
File “/home/mm/miniconda3/envs/tao_env_3.6/lib/python3.6/site-packages/tlt/components/instance_handler/local_instance.py”, line 296, in launch_command
docker_logged_in(required_registry=self.task_map[task].docker_registry)
File “/home/mm/miniconda3/envs/tao_env_3.6/lib/python3.6/site-packages/tlt/components/instance_handler/utils.py”, line 129, in docker_logged_in
data = load_config_file(docker_config)
File “/home/mm/miniconda3/envs/tao_env_3.6/lib/python3.6/site-packages/tlt/components/instance_handler/utils.py”, line 66, in load_config_file
“No file found at: {}. Did you run docker login?”.format(config_path)
AssertionError: Config path must be a valid unix path. No file found at: /home/mm/.docker/config.json. Did you run docker login?

I did run docker login nvcr.io before launching !tao bpnet, but I didn’t found any file when I did cat /home/mm/.docker/config.json. So to fix this problem I did sudo cp -r /root/.docker /home/mm/.docker, but !tao bpnetstills show the same message.

Content of /root/.docker /home/mm/.docker:

{
“auths”: {
nvcr.io”: {
“auth”: “JG9hdXRodG9rZW46T0dsb05ERnNPRzF5TlhScE1tZG5kV3c1T0c1bE1qSTNaV2M2WVRoalkyWTJaREl0TXpSaU5DMDBPVEExTFdGaE9UVXROMlpsTXpKa01XWXhNbU02”
}
},
“HttpHeaders”: {
“User-Agent”: “Docker-Client/19.03.9 (linux)”
}
}

!tao info returns me:

Configuration of the TAO Toolkit Instance
dockers: [‘nvidia/tao/tao-toolkit-tf’, ‘nvidia/tao/tao-toolkit-pyt’, ‘nvidia/tao/tao-toolkit-lm’]
format_version: 2.0
toolkit_version: 3.22.05
published_date: 05/25/2022

Output of sudo docker login nvcr.io:

sudo docker login nvcr.io
[sudo] password for mm:
Authenticating with existing credentials…
WARNING! Your password will be stored unencrypted in /root/.docker/config.json.
Configure a credential helper to remove this warning. See
docker login | Docker Documentation

I also have the same problem with GestureNet, it seems like no TAO command will work.
Thanks in advance.

I solved the issue, it’s just that TAO didn’t have the permission to open the file.
If this can help someone, I did:

sudo chown “$USER”:“$USER” /home/“$USER”/.docker -R
sudo chmod g+rwx “/home/$USER/.docker” -R

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.