docker.errors.DockerException: Credentials store error: StoreError

I want to know how to solve this error. I think this is relevant to “docker login nvcr.io”. Because I fix docker login error by this issue yesterday.
(Document how to initialize docker-credentials-pass · Issue #102 · docker/docker-credential-helpers · GitHub)

Network Type : Bpnet

Issue is reproduced by this command:

!tao bpnet dataset_convert
-m ‘train’
-o $DATA_DIR/train
–generate_masks
–dataset_spec $DATA_POSE_SPECS_DIR/coco_spec.json

This error occurs in train, inference code too.

And I want to ask 1 more question that is there any ways to download tao toolkit version 3.22.02 because my GPU is RTX3080 now.

Can you run below successfully?
$ docker login nvcr.io

Also, how about below command? Open a new terminal,
$ tao bpnet run /bin/bash

For old version of tao container, please refer to TAO Toolkit for Computer Vision | NVIDIA NGC
$ docker run --runtime=nvidia -it --rm --entrypoint=“” nvcr.io/nvidia/tao/tao-toolkit-tf:v3.22.05-tf1.15.5-py3 /bin/bash

  1. Can you run below successfully?
    Yes, I can see the Login Succeeded

  2. The result of “$tao bpnet run /bin/bash” in a new terminal
    Same error occurred (: Permission Denied)


Did you keep the error log? What is the error when you run $docker login nvcr.io ?

When I try to docker login nvcr.io and insert $oauthtoken, password, My error was

Error saving credentials: error storing credentials - err: exit status 1, out: pass store is uninitialized

Could you share the result of $ cat ~/.docker/config.json ?

This is the result of $cat ~/.docker/config.json
스크린샷, 2023-01-09 15-19-15

image

It is not expected. Usually there should be ngc key in
nvcr.io”: {yourkey}

When you run docker login nvcr.io,
Please enter exactly: $oauthtoken
And then when it asks for passwd, please enter your ngc key.

Even if I log in normally, nothing appears after the nvcr.io
스크린샷, 2023-01-09 15-35-34

And also If I try to type a key myself like “nvcr.io” :{“my key”}, the error occurred like this

Did you ever run $ ngc config set ?

I didn’t run that code after I solved the login problem. If my current key doesn’t end with “M2M1”, should I enter my current ngc key?

Please enter your latest ngc key.

I enter my latest ngc key and docker login nvcr.io again but config.json file doesn’t change. Also, after I do $docker login nvcr.io and repeat it on the same terminal, the terminal asks me for username and password again.

image
On my side, there is not above line.
Not sure why your config.json has this line.

After clearing that line, the error disappeared and the key was recorded in config.json. There is no more gpg key errror. Thanks!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.