Unable to log into nvcr.io docker account

I’m attempting to work through the TAO toolkit example Jupyter notebook. I’ve followed the instructions for signing up for an NGC account and I tried to log into docker using the instructions provided:

docker login nvcr.io

Username: $oauthtoken
Password: <MY API KEY>

However, I get the following response:

Error response from daemon: Get "https://registry-1.docker.io/v2/": unauthorized: incorrect username or password

The thing is: I already have the TAO docker image pulled (nvcr.io/nvidia/tao/tao-toolkit-tf) however when I try to kick off a model training job using the tao CLI

tao classification train -e $SPECS_DIR/classification_spec.cfg -r $USER_EXPERIMENT_DIR/output \
                        -k $KEY --gpus 2 \
                        --init_epoch N

I get this:

AssertionError: Config path must be a valid unix path. No file found at: /home/<user>/.docker/config.json. Did you run docker login?

Help is appreciated.

Please check if your ngc key is correct. Double check via TAO Toolkit Quick Start Guide — TAO Toolkit 3.0 documentation

Get an NGC account and API key:

Go to NGC and click the TAO Toolkit container in the Catalog tab. This message is displayed: “Sign in to access the PULL feature of this repository”.

Enter your Email address and click Next, or click Create an Account.

Choose your organization when prompted for Organization/Team.

Click Sign In.

Log in to the NGC docker registry (nvcr.io) using the command docker login nvcr.io and enter the following credentials:

a. Username: "$oauthtoken"
b. Password: "YOUR_NGC_API_KEY"

Hi Morganh,
Thanks for your help. I followed the instructions exactly as indicated above and it doesn’t work. I’ve tried regenerating the API key a few times just to be sure.

Can you share the full log when you run
docker login nvcr.io

Hi Morganh,

Sure here it is:

(tao-testing) ~/Projects/tao-testing$ docker login nvcr.io
Username: $oauthtoken
Password:
Error response from daemon: Get "https://registry-1.docker.io/v2/": unauthorized: incorrect username or password

(The value for password is copied and pasted from the API Key setup screen).

@kayccc ,
Do you have any idea for this user’s incorrect password?
Not sure if there is an issue in his account.

Hi @mbarna ,
Can you reset the ngc key and retry?

Hi @Morganh ,

It now is working, inexplicably. I had previously tried several times to reset the API Key, without success. I’m not sure what has changed now, but the issue seems to be resolved. Thanks for your support.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.