TeamViewer crash, cannot find OpenGL

Thanks for the post in the link below, of installing TeamViewer
https://devtalk.nvidia.com/default/topic/1048281/jetson-tx2/how-to-install-teamviewer-/post/5319874/#5319874

I was able to use teamviewer host following the link’s steps on the TX2 dev kit running L4T R32.1 Ubuntu 18.04
But once I restarted the tx2, I get the error:

$ ./opt/teamviewer/tv_bin/TeamViewer

ERROR: ld.so: object ‘libgtk3-nocsd.so.0’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
Gtk-Message: 12:54:22.329: Failed to load module “unity-gtk-module”
Gtk-Message: 12:54:22.495: Failed to load module “canberra-gtk-module”
Gtk-Message: 12:54:22.502: Failed to load module “canberra-gtk-module”
QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlagsQSurfaceFormat::FormatOption(), depthBufferSize -1, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize 8, stencilBufferSize -1, samples -1, swapBehavior QSurfaceFormat::SwapBehavior(DefaultSwapBehavior), swapInterval 1, profile QSurfaceFormat::OpenGLContextProfile(NoProfile))

Aborted (core dumped)

The same seems to happen when I try remote in.
Teamviewer shows the tx2 as available for remote connection, and when I click to remote in, tt shows the TX2 desktop on the client for a split second and closes immediately.

If I run glxinfo -B on the tx2, I get
“bash: glxinfo: command not found”

Any ideas how to get it working?

“glxinfo” is part of the “mesa-utils” package:

sudo apt-get install mesa-utils

(don’t know about the other issues)

Do you have a monitor plugged into the TX2? TeamViewer doesn’t like headless environments. I know you use to have to get a dummy HDMI monitor and plug it into your Pi/NUC in order to use TeamViewer on it.

Thanks. Glxinfo seems to work fine (glxinfo -B output below)

name of display: :0
display: :0  screen: 0
direct rendering: Yes
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: NVIDIA Tegra X2 (nvgpu)/integrated
OpenGL core profile version string: 4.6.0 NVIDIA 32.1.0
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.6.0 NVIDIA 32.1.0
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)

OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 32.1.0
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20

Yes. I have a monitor plugged in. It’s a 1920x1920 hdmi screen.

Have you solved this problem? I’m having the same issue.

No. I haven’t got any further on that. Also, teamviewer would sometimes halt/pause the booting process for 1:30min with a… job? I don’t know what that was supposed to do, but not nice as well.

I gave it a go with NoMachine instead of teamviewer for the tx2, and it works like a charm over the local network. I haven’t managed to use NoMachine over the internet, though.

Is possible to use NoMachine though internet, like TeamViewer, without port forwarding?

I heard it is possible using SSH. NoMachine has the option when you go to connect to choose between their off-the-shelf NX protocol, which works over the local network, or SSH, if you set it up to work over the internet. I haven’t looked at it, as I don’t need it now.