Tegra-i2c 7000c400.i2c: no acknowledge from address 0x3c

Hi I’m currently working with JetBot. I’m done with the hardware setup, while doing the software setup using an sd card image though - I’m seeing this error on my screen while booting :- “tegra-i2c 7000c400.i2c: no acknowledge from address 0x3c”
I’m able to give my username and password as input but nothing happens after that and this error continues to pop on screen. I have flashed the sd card multiple times but the error still persists.

hello user62388,

i2c no ack failure usually caused by regulator issue.
could you please review all your peripheral devices and check they’re given power supply correctly .
thanks

hi thanks for replying. I’ve checked the peripheral devices they are given power correctly. is there any other possible reason for this issue? maybe something related to sd card image? I’ve tried flashing my sd card with the latest version and one of the older versions of jetbot though, nothing worked.

hello user62388,

what’s device that using the 0x3c, could you please try disable from kernel layer to narrow down the issue,

hi thanks for your help but i successfully logged in using headless mode. Although Tegra I2C error still pops up when i try to login through head mode.

for anyone who’s facing the same issue here’s what i did :

i used a sd card which was already flashed with the jetpack image. I had previously setup my jetson nano using that sd card.

i used that same card and flashed it with the jetbot image thats provided on the official page
(i didn’t format it)
after that when i tried to login using my old credentials (the one i had set when i was setting up jetson nano) i got this error

this error pops up because the RSA key for the ip address has been changed but its still trying to map this ip address with the older RSA key (which was set while setting up jetson nano)

so all you need to do is delete the older rsa key for your ip address by running the following command

ssh-keygen -R <ip_address>

after that try logging in again using the ssh command using jetbot as username and password:
ssh jetbot@<ip_address>
password : jetbot

That should work.