Tensorflow for Jetpack4.2 on Jetson TX2


I am a newbie here.

I downloaded and installed Jetpack 4.2 on Jetson TX2. I trained my models using python 3.5 and I cannot run them with Jetpack 4.2 as Jetpack 4.2 has python 3.6 version.

So, I tried downgrading my python 3.6 to python 3.5 version and tried getting all the libraries working for python 3.5. But, I am facing a problem here as Jetpack 4.2 doesn’t have a Tensorflow version for python 3.5.

I need a tensorflow version that can work with my python 3.5 on Jetpack 4.2.
(The reason why I am using Jetpack 4.2 is because I want my models to run on Jetson Nano which supports Jetpack 4.2. So, I am validating Jetpack 4.2 on Jetson TX2 to work later on Jetson Nano).

Please help.


Python3.6 is the default python3 version on the Ubuntu18.04.
So the libraries in JetPack4.2 are all using python3.6 rather than v3.5.

May I know the error when you run your application with python3.6.
If your source is a tensorflow application, it should be much easier to upgrade your implementation into python3.6.

We have another older JetPack3.3 using Ubuntu16.04 which is using python3.5 by default.