How to install Tensorflow in Jetson tx2 ?

Hello

I have installed the jetpaack on the board successfully, but failed to install the tensorflow library.

I have tried installing via pip.(Error : The version does not satisfy the requirements) I also tried installing from anaconda but that also failed to install.
I have then installed bazel then tried installing tensorflow from the sources. That also gived me an error.

Below is the link for my error message : https://user-images.githubusercontent.com/1786477/27111755-24ea4b46-5067-11e7-9c71-130a9426a2a4.png
This is the link from which I tried installing the tensorflow from sources:

https://github.com/jetsonhacks/installTensorFlowTX2

Kindly, please suggest me a way to intsall the tensorflow library.

Hi,

From the error message, the issue is caused by different package version.

The page you shared is for JetPack 3.0.
If you are interested in JetPack3.1, please check this tutorial:

Thanks.

Thanks it worked

Do this install tensorflow-gpu version on Jetson?

[Answer] : Yes it installs the GPU version

hello , i follow this instruction:
pip3 install --extra-index-url https://developer.download.nvidia.com/compute/redist/jp33 tensorflow-gpu
or
pip install --extra-index-url https://developer.download.nvidia.com/compute/redist/jp33 tensorflow-gpu
still fail as below:

Looking in indexes: https://pypi.org/simple, https://developer.download.nvidia.com/compute/redist/jp33
Collecting tensorflow-gpu
Could not find a version that satisfies the requirement tensorflow-gpu (from versions: )
No matching distribution found for tensorflow-gpu

Environment:
Python 3.6.7 (default, Oct 25 2018, 09:16:13)
Python 2.7.12 (default, Nov 12 2018, 14:36:49)
JetPack 3.3
Nvdia jetson tx2 - 64bit arm cortex-A57 CPUs

Hi,

Please execute the installation command directly on the Jeston.
The python3 version of JetPack3.3 should be 3.5, rather than 3.6.7.

Thanks.

hi,AastaLLL:
I executed on Jetson and switch python to 3.5.0, finally it is work.
And the tensorflow-gpu version is 1.9.0+nv18.8
is it possible upgrade the version?
thanks

Hi,

We only release the package for the default python version.
python 3.6 for Ubuntu-18.04 on Xavier
python 3.5 for Ubuntu-16.04 on TX2.

For other python versions, you can try to build it from the source:
https://github.com/peterlee0127/tensorflow-nvJetson

Thanks.

Hi, AastaLLL:
Does Jetpack 4.2 support to TX2?
If it is, the version of python is greater than 3.6?

Hi,

YES. JetPack4.2 also supports TX2.
The default python3 version is v3.6 with Linux-18.04.

Here is the TensorFlow package for JetPack4.2:
https://devtalk.nvidia.com/default/topic/1038957/jetson-tx2/tensorflow-for-jetson-tx2-/post/5278617/#5278617

Thanks.

Hi, AastaLLL:
Is it possible to install Pytorch 1.0 with JetPack4.2 on TX2 too?
Thanks.

Hi, peter_hsu

Please check this topic for the pyTorch on JetPack4.2:
https://devtalk.nvidia.com/default/topic/1049071/jetson-nano/pytorch-for-jetson-nano/

This package is built with Xavier, TX2 and Nano compute capacity.
So you can install it directly with pip on TX2.

Thanks.

while installing the TensorFlow I am getting this error.
ERROR: Could not find a version that satisfies the requirement tensorflow-gpu==1.9.0+nv18.8 (from versions: none)
ERROR: No matching distribution found for TensorFlow-gpu==1.9.0+nv18.8
I also tried with a different version of tensor flow (1.11.0,1.12.0,1.8.0) and Nvidia version(19.1,18.8,19.01) but cannot be able to install the TensorFlow.
Please help me…