Tensorflow install still not working

Hi everyone,

I’m using a Jetson AGX Xavier with JetPack version 4.5 and Ubuntu 18.04 and I’m working in a virutalenv with Python 3.8.0 (64-bit) and pip version 21.3.1.

I followed the tensorflow installation guide according to Installing TensorFlow For Jetson Platform :: NVIDIA Deep Learning Frameworks Documentation and successfully executed the 4 steps of it. On executing the command of step 5:
sudo pip3 install --pre --extra-index-url Index of /compute/redist/jp/v45 ‘tensorflow<2’
I get the following error:
ERROR: Could not find a version that satisfies the requirement tensorflow<2 (from versions: none)
ERROR: No matching distribution found for tensorflow<2

I can’t find a fix for that. Has someone an advice for this?

Best regards,


Please note that we only provide the default python version package.
On JetPack 4.5, it is python v3.6.

For another python version, please build it from the source.
You can find an example below:


It still throws the same error when I’m using Python Version 3.6.0 or 3.6.9 !

Also I tried to install it from Source with the Github Repository you have attatched, but for my Tensorflow Version I need (1.15) it demands a Jetpack version of 4.3 and via the SDK Manager you can only downgrade to a version of 4.4 but none of the earlier ones. I think the JetPack Version 4.3 is needed because the install_tensorflow1.15.sh script requires Cuda 10 but I have a Cuda 10.2. Is there a way to manuall downgrade to Jetpack 4.3?

So I managed to fix the error, the problem was that my pip was linked to python 3.7, so whenever i installed something with pip it was executed with python 3.7 - i removed python 3.7 and again installed pip with python 3.6, and then everything worked fine !

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.