Tensorflow on xavier nx python3.8 Jetpack4.6 image

Trying to follow Learning Deep Learning book (Magnus Ekman) installing a DL framework using Xavier NX device with latest Jetpack (4.6) and python3.8. Need help with No matching distribution found for tensorflow error on p. 628. Using virtualenv on ubuntu 18.04.

After several days of trying multiple approaches to install tensorflow on
a Jetson Xavier NX with ubuntu 18.04, I need some help.

The process on
https://docs.nvidia.com/deeplearning/frameworks/install-tf-jetson-platform/index.html
is not working for me.

sudo pip3 install --pre --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v46 tensorflow yields:
ERROR: Could not find a version that satisfies the requirement tensorflow (from versions: none)

Q. What are the specific requirement to install the latest tensorflow on the Jetson Xavier NX?

I have resolved my issue with pip install error message:
I was using python3.8 in a virtual environment.
I switched to python3.6 in a virtual environment and
no error message.

Conclusion: the pip wheel definitions seem to be very restrictive.