Tensorflow is not detecting gpu in jetson orin

when i run my yolov3 algorithm in tensorflow then the program is running on cpu not in gpu. Tensorflow is unable to detect any gpu in jetson orin. i have installed tensorflow as per the guidance given by the nvidia

Your topic was posted in the wrong category. I am moving this to the Jetson AGX Orin category for visibility.

1 Like


May I know how you install the TensorFlow package?

We tested the version 2.9.1+nv22.07 package and it can detect Orin GPU architecture correctly.

$ sudo pip3 install --pre --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v502 tensorflow==2.9.1+nv22.07
$ python3
>>> import tensorflow as tf
>>> tf.test.is_gpu_available()
2022-08-22 10:58:55.783605: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1532] Created device /device:GPU:0 with 22644 MB memory:  -> device: 0, name: Orin, pci bus id: 0000:00:00.0, compute capability: 8.7


i have installed tensorflow 2.10.0-rc0 by following the description mentioned in the nvidia website.
After following your step of installing tensorflow 2.9 , it is now telling DNN library not found although it can now detect the Orin GPU. Can i install cuda 11.2 and cudnn 8.1 in jetson orin ?


Sorry that you will need to use the CUDA and cuDNN package from JetPack.
Currently, it is CUDA 11.4 and cuDNN 8.4 for Orin.

Could you share the script/test to reproduce the DNN library error?

For the previous error, the default command links to a CPU package from a third party.
So please specify the version to get the correct package.
We are checking this issue with our internal team. Will share more information with you.


solved the problem. For orin i used below command

sudo pip3 install --pre --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v50  tensorflow==2.9.1+nv22.06

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.