TESLA M10 driver?

Good afternoon,

I am going to tell you about a problem I have with a customer and the situation in which I find myself, since Nvidia and PNY do not give me support for this card or for the use that my client wants to give him.

The issue is the following:

I have a clone computer which has a M10 card and a TITAN V card. This computer is used for scientific data processing and all kinds of files, ranging from gb to tb.

The problem is the M10 graphic that the system does not recognize it, it uses an Ubuntu system, which in the nvidia panel if it reflects the 4 memory modules and if it recognizes the model of the card as TESLA M10.

In the information tells me that in each module are entering 18w and that its use is 0%, the temperature starts normal 35 º, 40 º. As time goes by without any data processing the graphic starts to heat up by itself reaching a temperature of 90 ° then I decided to turn off the system as it did not seem normal and more with a passive cooling graphic like this.

After a few minutes I start the computer and try to launch a process for both graphics, but this process only runs on the TITAN V in the tesla m10 still does not “recognize it”.

For ease and compatibility I opted to change the disk and install a w10 from 0 clean to see if from Windows to get it to work.

At the time of booting the desktop update the system to the maximum, I recognize the TITAN V and I download the Gforce to see if the tesla m10 I get from the panel nvida, I do not get. In the device manager it shows me the 4 memory modules of that card, but I can’t install any driver. The card starts to warm up on the desktop with virtually no stress for it.

I tried this card in the 3 PCI available on the board and got the same result.

Since from Nvidia and PNY tell me that these cards are only for vgpu and desktop virtualization and also have to be used in a certified servers and with a license of this type of “software”.

My question in this post is, if there is any possibility to work with this TESLA M10 graphics card for scientific data processing?

I have tried with other drivers to see if I could “fit” m60, m6, etc for Windows server and ubuntu on both platforms without any possibility or any result.

Please if anyone has any information or if this card has a hardware lock which does not allow such use.

Best regards and thanks!

Translated with www.DeepL.com/Translator (free version)