The following packages have unmet dependencies

I refer this page(CUDA Toolkit 11.3 Downloads | NVIDIA Developer to install cuda CUDA Toolkit. But it last occur follow text:

You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
cuda-drivers-465 : Depends: libnvidia-compute-465 (>= 465.19.01) but it is not going to be installed
Depends: libnvidia-gl-465 (>= 465.19.01) but it is not going to be installed
libnvidia-decode-465 : Depends: libnvidia-compute-465 (= 465.19.01-0ubuntu1) but it is not going to be installed
libnvidia-ifr1-465 : Depends: libnvidia-gl-465 but it is not going to be installed
nvidia-compute-utils-465 : Depends: libnvidia-compute-465 but it is not going to be installed
nvidia-driver-465 : Depends: libnvidia-gl-465 (= 465.19.01-0ubuntu1) but it is not going to be installed
Depends: libnvidia-compute-465 (= 465.19.01-0ubuntu1) but it is not going to be installed
nvidia-utils-465 : Depends: libnvidia-compute-465 but it is not going to be installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).

And now I use apt to install other software . It can’t work normally. It also occur above error. How can I resolve this question?

My board is jetson xavier nx. The system is ubuntu 18.04.

I set software centre to restricted. And run follow command to resolve problem:

sudo apt-get -f upgrade