The following packages have unmet dependencies

Hi there,
I’m trying to upgrade Cuda to 10.1 on Ubuntu 18.04. I know this issue is very common and have read just about every answer to this question to no avail.

   Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    The following packages have unmet dependencies:
     cuda-10-1 : Depends: cuda-runtime-10-1 (>= 10.1.243) but it is not going to be installed
                 Depends: cuda-demo-suite-10-1 (>= 10.1.243) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

I’ve tried to install every broken package that is mentioned and get to the point where I just have nvidia-modprobe (>= 465.19.01) and nvidia-settings (>=465.19.01) to install but when I install these only 460 is available.

I feel that the problem is I’m not properly deleting all the dependencies for the previous version, but it’s not at clear to me why the suggested ways of doing this aren’t working.

Thanks a lot!