The NVIDIA RTX A6000 graphics card cannot install cuda-11.3

  • GPU: NVIDIA RTX A6000
  • Ubuntu: 20.04

An error occurs when I run sudo apt-get -y install cuda following the official guide for cuda-11.3:

A modprobe blacklist file has been created at /etc/modprobe.d to prevent Nouveau
from loading. This can be reverted by deleting the following file:
/etc/modprobe.d/nvidia-graphics-drivers.conf

A new initrd image has also been created. To revert, please regenerate your
initrd by running the following command after deleting the modprobe.d file:
`/usr/sbin/initramfs -u`

*****************************************************************************
*** Reboot your computer and verify that the NVIDIA graphics driver can   ***
*** be loaded.                                                            ***
*****************************************************************************

INFO:Enable nvidia
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
Loading new nvidia-465.19.01 DKMS files...
Building for 5.15.0-101-generic
Building for architecture x86_64
Building initial module for 5.15.0-101-generic
ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/nvidia-kernel-source-465.0.crash'
Error! Bad return status for module build on kernel: 5.15.0-101-generic (x86_64)
Consult /var/lib/dkms/nvidia/465.19.01/build/make.log for more information.
dpkg: error processing package nvidia-dkms-465 (--configure):
 installed nvidia-dkms-465 package post-installation script subprocess returned error exit status 10
Setting up libcusolver-dev-11-3 (11.1.1.58-1) ...
Setting up cuda-cupti-11-3 (11.3.58-1) ...
dpkg: dependency problems prevent configuration of cuda-drivers-465:
 cuda-drivers-465 depends on nvidia-dkms-465 (>= 465.19.01); however:
  Package nvidia-dkms-465 is not configured yet.

dpkg: error processing package cuda-drivers-465 (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Setting up cuda-cupti-dev-11-3 (11.3.58-1) ...
dpkg: dependency problems prevent configuration of cuda-drivers:
 cuda-drivers depends on cuda-drivers-465 (= 465.19.01-1); however:
  Package cuda-drivers-465 is not configured yet.

dpkg: error processing package cuda-drivers (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Setting up cuda-libraries-dev-11-3 (11.3.0-1) ...
dpkg: dependency problems prevent configuration of nvidia-driver-465:
 nvidia-driver-465 depends on nvidia-dkms-465 (= 465.19.01-0ubuntu1); however:
  Package nvidia-dkms-465 is not configured yet.

dpkg: error processing package nvidia-driver-465 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Setting up cuda-visual-tools-11-3 (11.3.0-1) ...
dpkg: dependency problems prevent configuration of cuda-runtime-11-3:
 cuda-runtime-11-3 depends on cuda-drivers (>= 465.19.01); however:
  Package cuda-drivers is not configured yet.

dpkg: error processing package cuda-runtime-11-3 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Setting up cuda-samples-11-3 (11.3.58-1) ...
Setting up cuda-command-line-tools-11-3 (11.3.0-1) ...
dpkg: dependency problems prevent configuration of cuda-demo-suite-11-3:
 cuda-demo-suite-11-3 depends on cuda-runtime-11-3; however:
  Package cuda-runtime-11-3 is not configured yet.

dpkg: error processing package cuda-demo-suite-11-3 (--configure):
 dependency problems - leaving unconfigured
Setting up cuda-documentation-11-3 (11.3.58-1) ...
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of cuda-11-3:
 cuda-11-3 depends on cuda-runtime-11-3 (>= 11.3.0); however:
  Package cuda-runtime-11-3 is not configured yet.
 cuda-11-3 depends on cuda-demo-suite-11-3 (>= 11.3.58); however:
  Package cuda-demo-suite-11-3 is not configured yet.

dpkg: error processing package cuda-11-3 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Setting up cuda-tools-11-3 (11.3.0-1) ...
dpkg: dependency problems prevent configuration of cuda:
 cuda depends on cuda-11-3 (>= 11.3.0); however:
  Package cuda-11-3 is not configured yet.

dpkg: error processing package cuda (--configure):
 dependency problems - leaving unconfigured
Setting up cuda-toolkit-11-3 (11.3.0-1) ...
No apport report written because MaxReports is reached already
                                                              Setting alternatives
update-alternatives: using /usr/local/cuda-11.3 to provide /usr/local/cuda (cuda) in auto mode
update-alternatives: using /usr/local/cuda-11.3 to provide /usr/local/cuda-11 (cuda-11) in auto mode
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for initramfs-tools (0.136ubuntu6.7) ...
update-initramfs: Generating /boot/initrd.img-5.15.0-101-generic
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for libc-bin (2.31-0ubuntu9.14) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
Errors were encountered while processing:
 nvidia-dkms-465
 cuda-drivers-465
 cuda-drivers
 nvidia-driver-465
 cuda-runtime-11-3
 cuda-demo-suite-11-3
 cuda-11-3
 cuda
E: Sub-process /usr/bin/dpkg returned an error code (1)

I suspect the issue is that the NVIDIA RTX A6000 graphics card is not compatible with nvidia-driver-465 , thus preventing the installation of cuda-11.3.

Is this the reason? Thanks

The 465 driver is outdated and won’t compile on any recent kernel. Please uninstall everything, then install the driver from ubuntu repo, possibly using the graphics driver ppa, then use the cuda repo to install only the “cuda-toolkit” metapackage instead of the “cuda” metapackage.

@generix , Thank you for your reply. Could you clarify what you mean by “install only the ‘cuda-toolkit’ metapackage”? Does this mean not to follow the official guide for installing cuda-11.3?

Thanks

Following the “official guide” was always bad, so it was now changed to install “cuda-toolkit” and not “cuda”.

1 Like

@generix , great! Thank you very much.

Only need to replace sudo apt-get -y install cuda with sudo apt-get -y install cuda-toolkit-11-3 in the Installation Instructions.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.