The system time cannot be saved

I installed the L4T 35.1.0 system. The system clock is set manually. After manually changing the time, if I reboot the device, the system does not retain the time.
I set the system time to the correct time, and then used the command “sudo hwclock --systohc” to save it to the RTC. After rebooting, the “sudo hwclock” command can return the correct time, but the time displayed by the system is incorrect.

Hi liuyuhangpro,

Are you using the devkit or custom board for Xavier NX?

Have you tried with the latest R35.5.0?

Please also share the result of the following command on your board.

$ zcat /proc/config.gz | grep CONFIG_RTC_HCTOSYS_DEVICE 

I’m using a devkit and haven’t tried R35.5.0.


After a few hours, when I check again using the “sudo hwclock” command, the returned time information has changed to January 1st, 2000.

I found out there is no battery on the devkit. I added a battery to the custom board, but the issue persists; after rebooting, the system time reverts back to a previous time.

Could you try to configure the following line in kernel config and rebuild kernel image and reflash the board to apply the change to check if it could help for your case?

1 Like

Switching to rtc0 worked. Thank you!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.