Trouble accessing OpenCL

I am exploring Dr. Moritz Lehmann’s open source FluidX3D code. It fails to compile on my machine.He provide a pre-compiled benchmark that fails to run for me. (Basic Tutorial - error when debug initiates · Issue #80 · ProjectPhysX/FluidX3D · GitHub) Lastly, I tried to run a “sanity check” Python script provided by Professor Jan Verschelde.

We have come to the conclusion that access to OpenCL is the most likely cause. I suspect it is something simple.

My machine is an Alienware X17R running Windows 11 Home in Developer mode. Are there any permissions or settings that I am overlooking?

Other apps like Blender, IndigoBench or CompuBench work fine on your laptop?

Deactivate Intel iGPU in device manager to either rule out or confirm that this GPU is the culprit.

SOLVED! That did the trick. I was wondering how the OS decided which Display Driver to use. Apparently, doesn’t!

Thank you so much!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.