Trouble with nvcc (Vista 64, VS2008, CUDA 2.1)

Hi

I have a trouble with starting nvcc compilations ***.cu file from command line (cmd), but from VS2008 I can do this.

c:\ProgramData\NVIDIA Corporation\NVIDIA CUDA SDK\projects\testirovanie>nvcc simpleTemplates.cu -run

simpleTemplates.cu

c:\cuda\include\host_config.h(95) : fatal error C1083: Cannot open include file: ‘stddef.h’: No such file or directory

I add a line compiler-bindir= c:\Program Files (x86)\visual studio 2008\VC\bin in my nvcc.profile. I see, that nvcc couldn’t find all ***.h files but all other lines, that i have tried to add in nvcc.profile like:

PATH += (TOP)/extools/bin;(TOP)/open64/bin;(TOP)/bin;(TOP)/lib; c:\Program Files (x86)\visual studio 2008\VC\include; C:\Program Files (x86)\visual studio 2008\VC\bin; … etc didn’t work.

Also I tried specifications like “–include-path; --pre-include; --system-include” and some other and they’re not help me too.

С:\Program Files (x86)\visual studio 2008\VC\include – this path contain file: ‘stddef.h’? but why nvcc don’t see it ??!!

Help me please!! What do I do wrong??

[codebox]c:\ProgramData\NVIDIA Corporation\NVIDIA CUDA SDK\projects\testirovanie>nvcc sim

pleTemplates.cu -run -dryrun

#$ SPACE=

#$ MODE=DEVICE

#$ HERE=C:\CUDA\bin

#$ THERE=C:\CUDA\bin

#$ TOP=C:\CUDA\bin/…

#$ PATH=C:\CUDA\bin/…/extools/bin;C:\CUDA\bin/…/open64/bin;C:\CUDA\bin/…/bin;

C:\CUDA\bin/…/lib; c:\Program Files (x86)\visual studio 2008\VC\include;C:\Pro

gram Files (x86)\visual studio 2008\VC\bin;C:\Program Files (x86)\visual studio

2008\VC\bin\common\inc;С:\Program Files (x86)\visual studio 2008\VC\include;C:\

Program Files (x86)\visual studio 2008\VC\bin;c:\Program Files (x86)\visual stu

dio 2008\Common7\Tools;c:\Program Files (x86)\visual studio 2008\VC\bin\common\

inc;C:\Program Files (x86)\visual studio 2008\Common7\Tools;c:\Program Files (x

86)\visual studio 2008\VC\atlmfc\include;c:\Program Files (x86)\visual studio 2

008\VC\crt\src\C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Progra

m Files (x86)\Microsoft SQL Server\90\Tools\binn;C:\CUDA\bin;C:\Program Files\T

ortoiseSVN\bin

#$ INCLUDES="-IC:\CUDA\bin/…/include" “-IC:\CUDA\bin/…/include/cudart”

#$ LIBRARIES= “/LIBPATH:C:\CUDA\bin/…/lib” cudart.lib

#$ CUDAFE_FLAGS=

#$ OPENCC_FLAGS=

#$ PTXAS_FLAGS=

#$ compiler-bindir=c:\Program Files (x86)\visual studio 2008\VC\bin

#$ PATH=c:/Program Files (x86)/visual studio 2008/VC/bin;C:\CUDA\bin/…/extools/

bin;C:\CUDA\bin/…/open64/bin;C:\CUDA\bin/…/bin;C:\CUDA\bin/…/lib; c:\Program

Files (x86)\visual studio 2008\VC\include;C:\Program Files (x86)\visual studio

2008\VC\bin;C:\Program Files (x86)\visual studio 2008\VC\bin\common\inc;:\Prog

ram Files (x86)\visual studio 2008\VC\include;C:\Program Files (x86)\visual stud

io 2008\VC\bin;c:\Program Files (x86)\visual studio 2008\Common7\Tools;c:\Prog

ram Files (x86)\visual studio 2008\VC\bin\common\inc;C:\Program Files (x86)\vis

ual studio 2008\Common7\Tools;c:\Program Files (x86)\visual studio 2008\VC\atlmf

c\include;c:\Program Files (x86)\visual studio 2008\VC\crt\src\C:\Windows\syste

m32;C:\Windows;C:\Windows\System32\Wbem;C:\Program Files (x86)\Microsoft SQL Ser

ver\90\Tools\binn;C:\CUDA\bin;C:\Program Files\TortoiseSVN\bin

#$ cl -D__CUDA_ARCH__=100 -nologo -E -TP -DCUDA_FLOAT_MATH_FUNCTIONS -DCUDA_NO_S

M_12_ATOMIC_INTRINSICS -DCUDA_NO_SM_11_ATOMIC_INTRINSICS -DCUDA_NO_SM_13_DOUBLE_

INTRINSICS “-IC:\CUDA\bin/…/include” “-IC:\CUDA\bin/…/include/cudart” -I. -

D__CUDACC__ -C -FI “cuda_runtime.h” > "C:\Users\Mike3b\AppData\Local\Temp/tmpxf

t_000011d0_00000000-3_simpleTemplates.cpp1.ii" “simpleTemplates.cu”

Internal error

[/codebox]

[codebox]C:\Users\Mihail>nvcc -V

nvcc: NVIDIA ® Cuda compiler driver

Copyright © 2005-2007 NVIDIA Corporation

Built on Sun_Dec_14_04:16:17_PST_2008

Cuda compilation tools, release 2.1, V0.2.1221

[/codebox]