trt-yolo-app compile error on TX2


trt-yolo-app (
when I compiled the trt-yolo-app on TX2, a make error occurs:

trt_utils.h:83:22: error: ‘nvinfer1::DimsHW YoloTinyMaxpoolPaddingFormula::compute(nvinfer1::DimsHW, nvinfer1::DimsHW, nvinfer1::DimsHW, nvinfer1::DimsHW, nvinfer1::DimsHW, const char*) const’ marked ‘override’, but does not override
     nvinfer1::DimsHW compute(nvinfer1::DimsHW inputDims, nvinfer1::DimsHW kernelSize,


Jetpack 3.3
DeepStream 1.5

Hi Vencent,
Looks TensorRT version is not correct.
Which Jetpack version are you using? This CL need Jetpack3.3.

wayne zhu

Sorry, Vencent.
Pls check this topics for this issue:

wayne zhu

@waynezhu i checked the issue and it`s the same as me.

ii  libnvinfer-dev                              4.1.3-1+cuda9.0                               arm64        TensorRT development libraries and headers
ii  libnvinfer-samples                          4.1.3-1+cuda9.0                               arm64        TensorRT samples and documentation
ii  libnvinfer4                                 4.1.3-1+cuda9.0                               arm64        TensorRT runtime libraries
ii  tensorrt                                                       arm64        Meta package of TensorRT

But I don’t know how to rollback TRT 4.0.4. Could you tell me the details.

You would need to use the DS2 version of the repo which works with Jetpack 3.3 / DS 1.5 on Tegra devices.

Here’s a link to the release tag -

The corresponding commit is - 7f27f22d674c64f4859dd1da896a43e35b0b9063


This is hell on earth. All the JetPack environment is so fragile and interdependent that it is impossible to run different kind of applications (gstreamer, deepstream) on the same jetson! I have just updated my system to 3.3 just to discover I have to rollback trt if I want to run yolo. What happens when I rollback? Will the “standard” deepstream work?


The dependency comes from the CUDA driver.
The update of Jetson OS is much more frequently.
It is not easy to share the package as the desktop environment, which may just have 16.04/18.04.

We add a list for pre-requirement of YOLO here.
It’s recommended to check which combination you want to use before the installation.