Trying to debug CUDA samples and hit an CUDBG_ERROR_INTERNAL(0xa) error. Please help!

Environment: WSL2 (Windows 10)
CUDA: 12.0
NVIDIA Driver: 528.02
GPU: GeForce RTX 3080 Laptop

I’m trying to test run CUDA-GDB on my local GPU. I have managed to set up the work environment when SSH-ing into a WSL docker container. However, I am unable to get things to work on my own device. The crux of the issue is that once I get to the stage where CUDA-GDB reached GPU code, the following is output.

[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/".
[Detaching after fork from child process 2091]
[New Thread 0x7fffef75e000 (LWP 2094)]
Error: Failed to suspend device for CUDA device 0, error=CUDBG_ERROR_INTERNAL(0xa).

I have tried a clean reinstall of WSL2 and CUDA, as is shown here. I have also tried rolling back the NVIDIA driver to 527.56, and it still does not work.

It is quite important to me that this gets working. Any help would be greatly appreciated!

Hi @s.gomezcullen
Thank you very much for your report. There are some known issues with using debugger on WSL: CUDA-GDB 12.0 documentation

Please try running the debugger using legacy back-end:


Hi @AKravets,

The solution for my case ended up was adding

export LD_LIBRARY_PATH=/usr/local/cuda-12.0/lib64${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}

regardless of the installation method used.

I used the deb (local) installation. I think an update to the post-installation section of the manual may help as this line should be added regardless of how CUDA is installed in WSL.

Hi @s.gomezcullen
Thank you for letting us know that you found the solution!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.