Trying to stream usb cameras over rtsp on Jetson Nano

I’ve tried the gstreamer instructions here: Jetson Nano FAQ
Vlc has not been able to connect to the opened stream, or open stream for me if I try to stream from vlc on the jetson side.
I’ve tried disabling OXMIL.
I know the video works because they are visible through vlc and other means of display,
Anyone know what other info I can provide to debug this issue?


One first step would be to check the GST_DEBUG output. Could you please provide the output log by preceding GST_DEBUG=2 in the test-launch command and also in the gst-launch command in the receiver end. Also can you please share the GStreamer pipelines that you are using in the test-launch command and the gst-launch command in the receiver side?

Jafet Chaves,
Embedded SW Engineer at RidgeRun
Contact us:
Developers wiki:

I don’t seem to have a way to modify the test-launch command, do you mean test-launch.c? the receiver end is also just vlc. The test launch command I’ve tried is:
./test-launch “videotestsrc is-live=1 ! nvvidconv ! nvv4l2h264enc ! h264parse ! rtph264pay name=pay0 pt=96”

./test-launch “v4l2src device=”/dev/video1" ! video/x-raw, width=1280, height=720, bitrate=1000000 ! tee name=t t. ! queue ! nvoverlaysink overlay-x=0 overlay-y=0 overlay-w=1280 overlay-h=720 t. ! queue ! omxh264enc ! video/x-h264, profile=baseline ! rtph264pay name=pay0 pt=96"

I have been using a windows computer on the receiver side and just trying to use VLC is there a better alternative?

Ravoik, I meant that you provide the output log of the following command:

GST_DEBUG=2 ./test-launch “videotestsrc is-live=1 ! nvvidconv ! nvv4l2h264enc ! h264parse ! rtph264pay name=pay0 pt=96"

You should be able to get the GST_DEBUG log when you run the test-launch application on the Jetson system with different pipelines as shown above.

Also can you also share the uri you are using with VLC? It should be given in the format rtsp://${IP_ADDRESS}:${PORT}/${MAPPING}

For your case you will have to make sure that the IP_ADDRESS is the address of the Jetson system, and by looking in the source code, the default port is 8554 and the stream id (MAPPING) is test

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.