TX2 4GB with R32.3.1 having issues with OTA version update

My company has a number of TX2 4GB modules in the field (and sealed up inside water/pressure resistant containers), we’d like to be able to upgrade the units without using the USB cable to flash the units. To this end I’ve been working on generating an OTA upgrade package. If I run through the Image-Based OTA Update process I run into errors. The OTA backup and package generation will work if I use ‘jetson-tx2-devkit’ and ‘R32-3’ <target_board> and <bsp_version> arguments, however when the I move the update package to the unit and attempt to use the ota update script it fails. The error being that the ota package is for a ‘jetson-tx2-devkit’ not a ‘jetson-tx2-devkit-4gb’. I went back and tried the process with ‘jetson-tx2-devkit-4gb’ as the <target_board> argument but the backup script fails because the 4GB version is not a valid target board. Will I be able to use the OTA updates for this or am I out of luck?

Hi iank,

We’re not support " Image-Based OTA Update" on TX2-4GB.
Please use below steps to upgrade your device:

$ sudo vim /etc/apt/sources.list.d/nvidia-l4t-apt-source.list
   deb https://repo.download.nvidia.com/jetson/common r32.6 main
   deb https://repo.download.nvidia.com/jetson/t194 r32.6 main
$ sudo apt update
$ sudo apt dist-upgrade

Right, got it. Could you explain why the 4GB is not supported? Perhaps, provide some insight into what differences between the 4GB and original 8GB that prevent the OTA feature from working? These units interface with our proprietary carrier board so we already modify the device tree and pinmuxing for the image we’d like to push out to the modules.

hello iank,

the image-based OTA feature in order to support the OTA update with layout changes.
this is only support with Xavier series, and Original Jetson TX2 modules.
furthermore, the OTA update through Debian package is supported since r32.3.1. as you’re based-on r32.3.1; there’s no need to use image-based OTA .