TX2 Drivers Help Needed


I tried installing drivers for a 7" touch screen and now when I try to login it restarts. Is there a way to revert or reinstall the correct drivers?

Im running:
#R28 (release), REVISION: 1.0, GCID: 9379712, BOARD: T186REF, EABI: aarch64

If in text mode (such as via CTRL-ALT-F2 or serial console or ssh) you run this command you’ll see the checks on relevant user space libraries:

sha1sum -c /etc/nv_tegra_release

If those are “ok”, then the issue is something else, e.g., if you didn’t set CONFIG_LOCALVERSION correctly your kernel won’t be able to find any modules. What do you get from “uname -r”? Are the modules available at “/lib/modules/$(uname -r)/”?

Please share what did you install into your board.

I ended up losing terminal capabilities while trying to fix it last night. I am learning as I go as I do not have a computer science background.

I am currently restoring the TX2 via JetPack 3.2.

For reference, I was using a 7" touch screen display. I could not get the correct resolution (800x480) set so I tried installing the drivers that came with the display.


Thanks for the quick responses!

I know nothing about that display, but possibly the drivers you mention are for touch and not for video. This kind of looks like HDMI, but can you confirm? If HDMI it has the possibility to auto configure resolution.

The Jetson gets information about the monitor from the EDID data (which is over the DDC wire of HDMI, DisplayPort, or some DVI…but never VGA or parallel LVDS). If the Jetson supports a mode in EDID, then it should work (not all modes will work…the Jetson has a fixed list of modes). Should there be no EDID data, then the display will not be supported unless you have an adapter which provides EDID.

Assuming it is connected correctly, then you can see what the video driver thinks of the EDID modes the monitor reports. You would look at “/var/log/Xorg.0.log” after adding this to the ‘Section “Device”’ of file “/etc/X11/xorg.conf”:

Option "ModeDebug"

Note that a correctly Jetson already has a video driver for the video GPU which is present. Monitors never use a video driver. In the old days of VGA a driver disk which came with the monitor simply had the data in it which the DDC/EDID wire provides automatically in modern times. Odds are any driver you get is for touch components and not video. If the existing video driver won’t work, then you won’t be able to use the monitor.

Correct, this display is HDMI and connects using usb for touch capability. The touch did work, but sounds like the Jetson does not have the correct mode. I did try to manually add a mode, without success.

Once I am done restoring the TX2 I will take a look at what EDID modes the monitor reports!

Manually adding a mode won’t work. The mode has to come from the EDID, and that mode must be supported by the existing video driver. Thus the suggestion to see what the driver thinks of the modes via the “ModeDebug” option (this option causes the log to contain the driver’s opinion about every mode the monitor reports in EDID).

I have a fresh install on my TX2. After adding the “Option ModeDebug” I do not see 800x480 as an option in the Xorg.0.log. Does this mean I am out of luck with this screen?

With that monitor connected what do you see from:

sudo cat /sys/kernel/debug/tegradc.0/edid

See below.

Screenshot from 2018-05-02 21-23-24.png

Can you copy and paste this? I need to be able to paste it into http://www.edidreader.com and cannot do that with an image.

00 ff ff ff ff ff ff 00 10 ac 7a a0 53 39 37 30
13 18 01 03 80 34 20 78 ea ee 95 a3 54 4c 99 26
0f 50 54 a1 08 00 81 40 81 80 a9 40 b3 00 d1 c0
01 01 01 01 01 01 28 3c 80 a0 70 b0 23 40 30 20
36 00 06 44 21 00 00 1a 00 00 00 ff 00 59 4d 59
48 31 34 35 41 30 37 39 53 0a 00 00 00 fc 00 44
45 4c 4c 20 55 32 34 31 32 4d 0a 20 00 00 00 fd
00 32 3d 1e 53 11 00 0a 20 20 20 20 20 20 00 48

So the EDID data is valid and the video driver is able to see EDID. If you paste that information into http://www.edidreader.com and click on “standard display modes” you should be able to go to the Xorg.0.log with the ModeDebug option and see the driver comment on each of those modes (there will be other mode comments as well).

FYI, your monitor does not claim to support “800x480”. It is the monitor itself which is denying the ability to use this setting.