TX2 GBE LED operation

Please explain the use of the three GBE_LINK signals as the use of GBE_LINK_100 in Figure 16 of the Jetson TX2 OEM Product Design Guide on a Gigabit link seems odd. Might expect the LED to be controlled by the GBE_LINK_1000 (F46) output on a Gigabit link?

A table showing the state on the GBE_LINK_ACT, GBE_LINK_100 and GBE_LINK_1000 signals at 100Mb/s and 1000Mb/s connection speeds would be useful.


The operation mode of 2 LEDs combination is customizable, the Ethernet chip in module is BCM54610, you can check its datasheet for the detail configuration and so implement the settings as you wish.

Datasheet for BCM54610 is only available under NDA. Surely, NVIDIA can provide a description of how these pins operate on the TX2 carrier board.

Hi kevan.johnston,

GBE_LINK_1000 to LED3

Please explain the use of GBE_CTREF. NVIDIA’s Demo board do not use it.

It is null connection, just reserve for future possible usage.

Using JetPack 3.2 the GBE_LINK_ACT LED is not working, both on the P2597 baseboard and on our custom carrier board. Any hints?

I have the same question as you. Have you finished yet?How to solve it??

No, I have not solved it.

From what I have read, we need to set DMIC4_CLK to low at boot time in order to ensure that the PHY chip will enter RGMII mode.

Do you know how to do that?

I have just begun to solve this problem.No idea yet.So find out if there are any friends with the same problem as me in the post. If you have solved it later, please let me know.
Thank you !!!

I will let you know as soon as I solve it, please do the same with me. The Ethernet connection works but we cannot ship with the ACT-LED not working.

Do you use a custom carrier?
Take a look at Figure 15 of the OEM Design Guide on page 33: DMIC4_CLK is pulled-up internally. This signal needs to be low a boot time for the GbE PHY to enter into the right LED mode.

Hi mgjet and 1481453418,

I would like to get more clear for your purpose. Which LED mode do you want to use?

Do you want to use default LED mode or LOM LED mode?

We want the default LED mode, not the LOM-LED mode. We need 2 LEDs working: LINK and ACT. After flashing Jetpack 3.2.1 only the LINK-LED is working. ACT-LED is always dark, on the development kit as well as on our custom carrier.

Hi WayneWWW,
The LED light connected to the E47/GBE_LINK_ACT indicates the state of network activity.The ideal situation is twinkling, but it’s not bright now.I want to solve this problem

To be more precise, we need
GBE_LINK_ACT# at pin E47 to show Ethernet activity
GBE_LINK100# at pin F50 to show an active Ethernet link.
exactly like it is wired on the development kit P2597-B04

Have you solved it?

No, no further answer from support or anybody else.

Hi WayneWWW,
how do we ensure that the default LED-mode is enabled during boot-up?
Do you know how to set the output level of DMIC4_CLK to low during boot-up?


I am checking this with internal team. Sorry for late response.

If there is any update, I’ll update it here.

Please refer to this driver in kernel source.


This file is the driver for brcm phy. If you have the datasheet for bcm54610, you should be able to program the LED.