TX2 system configuration for deployment

Hello everyone,

I have several apps on jetson tx2 that are communicating with each other. They are using TensorRT, Qt and other libs.

I have configured autostart using autologin and startup application and its working, but I think its not the “right way” for deployment.

What I need:

  1. Autostart Qt app without login/desktop
  2. Customize nvidia icon on boot
  3. Make system safer from “hacking”

What I’ve tried:

  1. Make systemd scripts (doesn’t work for qt and cuda apps)
  2. This method https://devtalk.nvidia.com/default/topic/988275/tx1-disable-ubuntu-unity-and-start-qt-app-on-startup/ (doesn’t work too)

Has anyone had the same problems? Could you give me some advice for devOps technicians or tell your experience for tx2 project deployment?

Thanks and Best Regards.

You can certainly autolaunch applications using the existing GNOM ‘autostart’ primitives (Google it). That’s what we do. The machine boots, the ‘nvidia’ user or whatever logs in automatically, and our application suite starts up and maximizes itself.

You may also want to do other tasks as well such as call ‘jetson-clcoks’ to increase the frequency of the unit as well as ‘nvpmodel -m0’ to take things out of power saver mode.

I would avoid making custom systemd services in order to just launch an application.

Btw, if you operate without a monitor, then you might consider adding a virtual desktop (it is still X11 protocol, but the buffer is just RAM and doesn’t really connect to a monitor…a remote desktop can be connected to this from another computer if desired). I don’t have any recommendation for a particular virtual desktop, but others here can probably give good advice on that (e.g., something like TurboVNC or VirtualGL).

Hello all. Thanks for your replies!

Now i have another problem : when my qt app starting and working about 5-10 min, monitor turn off.
I added in ~/.xsession above exec command

xset -dpms s off

Now it start, works 5-10 min and freeze/hang : other apps works, write log, but the qt app don’t change icon. When i using autologin and startup application i don’t have this trouble

I suspect there is a gsettings command to do this, but I don’t know what it is. I’ve mostly just gone into the GUI and used the app for setting no desktop timeout. You might check out some of these URLs on the topic of gsettings and dbus:
https://devtalk.nvidia.com/default/topic/1043733/jetson-tx2/how-to-disable-screen-off-and-screen-lock-on-jetpack3-1-of-tx2-device/post/5294989/#5294989
https://devtalk.nvidia.com/default/topic/1043733/jetson-tx2/how-to-disable-screen-off-and-screen-lock-on-jetpack3-1-of-tx2-device/post/5295805/#5295805

I mention dbus because sometimes gsettings needs dbus information to know what to interact with. No guarantee this will help.