TX2 Usb 3.0 port damage after plugging USB Hub and some devices


Hi, we have Tx2 usb 3.0 port connected to USB Hub 4 port (self powered).
device that connected to USB Hub: 1xUSB Camera Logitech C920, 1xMouse+Keyboard, 1x Usb Touchscreen Cable, 1xArduino nano,
then on TX2 microusb port connected to Roboteq SDC2160

the first 5 minutes all is working fine, after that usb 3.0 port on TX2 and USB Hub was damage/not working

we change to other TX2, same problem (so we have 2pcs TX2 usb 3.0 port + 2xself powered Usb Hub broken already )

before this issue we have done arround 5projects working fine on usb 3.0 port, with same connection/configuration.

does anyone know what this is caused by? overcurrent? drawback current from self powered usb hub?


Hi, have you checked if any components on TX2 board broken/burned? In general, the USB port on board is strong enough as you can see the design in carrier board P2597 schematic in DLC. It might be damaged by over current caused by shorting between power and ground. Or might be damaged by ESD even though there are ESD protection on board.

I’m wondering if you can still get a directly connected keyboard or mouse to work on that port. Bypass the powered USB HUB to see if the HUB itself is an issue. Regardless, I’d monitor “dmesg --follow” and see what gets logged as you plug something in to that port. There is a lot that could go wrong (but normally would not go wrong), and just knowing it doesn’t work lacks any way of finding out part of the chain of hardware and software is failing. You might also add the output of “lsusb” and “lsusb -t” when the HUB is not plugged in, but just a keyboard is connected, then again when the HUB is plugged in (with the keyboard plugged in to the HUB and nothing else on the HUB).

we have checked no component burned, maybe any component burned inside, need to check one by one. unfortunately, we are not very familiar with electronics circuit.

we have checked on power source not short circuit. it suddenly not working.
we put TX2 on the top of acrilyc sheet

mouse directly connected to usb 3.0 port not working.
Usb hub not working also after checking with another pc.

So if the HUB failed, then it might have destroyed something on the carrier board. Or vice-versa. Can you see boot logs from a serial console, or at least via ssh? If so, then serial console logs would be quite important, but ssh logs would also be good. In the case of ssh you could post dmesg output, and also monitor “dmesg --follow” and see what happens in logs as you insert or remove a device (one known to work).

here is dmesg output, if lsusb not detect usb device

Would it be possible for you to attach actual logs rather than a screenshot? We only see the end result in a screenshot, but a serial console boot log, when attached to the forum, would allow text search all the way back to setup before the Linux kernel ever loads.

However, from that error, I will guess that this means there is some sort of signal quality issue. Burned wires and components would obviously be a signal quality issue, but there are other more subtle ways which are sometimes encountered in USB which might give that same error. I can only guess that the carrier board is damaged.

Do you have another dev kit? If you do, then you could swap modules and see if the issue sticks to the carrier board.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.