Tx2i: Unable to receive data on /dev/ttyS0 and ttyS0 group NOT reverting to dialout

We are getting the exact same behavior as Problem with send data through UART0 (ttyS0) but we cannot change the group to dialout with the mentioned commands.

Board: ConnectTech Spacely Carrier Board
Jetpack: 4.6.1
BSP: 32.6.1

We tried to disable the serial console by following the instructions in the aforementioned link but the group was stuck at tty instead of changing to dialout:

$ ls -l /dev/ttyS0
crw--w---- 1 root tty 4, 64 Mar  9 19:54 /dev/ttyS0
$ sudo systemctl stop nvgetty.service
[sudo] password for USER: 
$ sudo systemctl disable nvgetty.service
$ ls -l /dev/ttyS0
crw--w---- 1 root tty 4, 64 Mar  9 19:54 /dev/ttyS0

I also tried restarting after running the above commands but that didn’t help either.

$ sudo systemctl status nvgetty.service
● nvgetty.service - UART on ttyTHS0
   Loaded: loaded (/etc/systemd/system/nvgetty.service; disabled; vendor preset: enabled)
   Active: inactive (dead)

I discovered there is another service that might have something to do with ttyS0:

$ sudo systemctl status | grep tty
[sudo] password for USER: 
           │ │   ├─6593 /usr/lib/xorg/Xorg vt1 -displayfd 3 -auth /run/user/120/gdm/Xauthority -background none -noreset -keeptty -verbose 3
           │   │ ├─9800 grep --color=auto tty
             │ ├─serial-getty@ttyGS0.service
             │ │ └─6609 /sbin/agetty -o -p -- \u --keep-baud 115200,38400,9600 ttyGS0 vt220
             │ └─serial-getty@ttyS0.service
             │   └─5743 /sbin/agetty -o -p -- \u --keep-baud 115200,38400,9600 ttyS0 vt220

I tried

sudo systemctl stop serial-getty@ttyS0.service
sudo systemctl disable serial-getty@ttyS0.service

but ttyS0 was still stuck in tty group instead of dialout. Rebooting didn’t help either.

Hi qwertyuio,

Do you want to send/receive data on ttyS0 for custom usage?

You could refer to the following thread for disabling console output.
Disable console output to ttyS0 and read/write ttyS0 as UART device

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.