ubuntu 18.04+headless_390+intel iGPU after prime-select intel lost contact to GeFORCE 1050ti

Hi All,

I have a fresh ubuntu 18.04 installation.

I first enabled iGPU on bios


sudo apt install nvidia-headless-390 nvidia-settings nvidia-smi

and reboot.

Got into the login loop and did Ctrl+Alt+F3 to login.

Then prime-select intel and reboot.

now I have gdm3 but lost contact to the GeForce 1050ti.

when I typed nvidia-smi I get

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

The card is there though:

sudo lshw -c display
*-display UNCLAIMED
description: VGA compatible controller
product: GP107 [GeForce GTX 1050 Ti]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller cap_list
configuration: latency=0
resources: memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f7000000-f707ffff
description: VGA compatible controller
product: Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 09
width: 64 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:25 memory:f7400000-f77fffff memory:d0000000-dfffffff ioport:f000(size=64) memory:c0000-dffff

This is expected, prime-select intel turns off the nvidia gpu.
Try this:

  • sudo prime-select nvidia
  • add ‘nogpumanager’ kernel parameter
  • create /etc/X11/xorg.conf
Section "Device"
    Identifier     "intel"
    Driver         "modesetting"
    BusID          "PCI:0:2:0"
  • reboot

generix you da man!

thank you.

“”“This is expected,”“” Expected??? I have lost 2 hours trying to solve the problem, I had a very important meeting. Don’t you have QA testers department? I don’t know what are you playing, but you have caused a big problem for me.
good morning, Daniel Gimeno.

Daniel, maybe two words about it for explanation:

  • prime-select and gpu-manager are Ubuntu tools, nvidia has nothing to do with it, they’re only providing the driver. So you’re barking at the wrong tree.
  • the only intended function of prime-select intel is turning off the nvidia gpu for power-saving. So you can’t really complain that it does what it’s made for.

Sorry if yesterday I look liked barking, that was not my intention. I had dificult situation, I understand that those tools really coming from Ubuntu.
I’m sorry again.
Kind regards, Daniel.

Thank you!
I met the same problem and your solution works.

Hi @generix
I’ve just updated ubuntu 18.04.3 packages and lost Nvidia connection and cannot use screen which is connected to e-gpu
I finally reinstalled ubuntu and to plain 18.04 and on default drivers screen started to work, after changing drivers to Nvidia 435, I am getting login loop and have no idea how to solve it :(
I found this conversation and as I see your answer helped someone but when I’ve tried use you solution then I have no idea how to do this:

  • add ‘nogpumanager’ kernel parameter

Could you help me with that ?

It looks like I can use recommended upgrades on ubuntu because they can break the Nvidia connection :/

Thanks for any help with that issue

1 Like

I’m also confused about how to implement:

  • add ‘nogpumanager’ kernel parameter

Could anyone help me with it?
Thanks in advance.

Kernel parameter: