415 Installed and Nvidia selected on prime, but still using intel graphics

I installed the nvidia-415 for mine gtx 1050 ti on a dell xps 9570.
Installation seems ok, and I selected Nvidia on prime, but on preferens/details I still seeing Intel UHD Graphics 630 as graphics.
I attach log and screenshots.
Thanks to all can help me.

nvidia-bug-report.log.gz (1.01 MB)
nvidia-bug-report2019-02-05.log.gz (1.03 MB)

Screenshot from 2019-01-28 23-16-52.png

Logout from your currenet session or restart pc to make this change effctive.

Btw , that Ubuntu system info screen always shows Intel on there. Ignore it.

When you run inxi -SMGxx command , output should be like that.

Graphics:
  Device-1: Intel vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:591b 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK 
  driver: nvidia v: 415.27 bus ID: 01:00.0 chip ID: 10de:1c8d 
  Display: x11 server: X.Org 1.19.6 driver: modesetting,nvidia 
  unloaded: fbdev,nouveau,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2 v: 4.6.0 NVIDIA 415.27 
  direct render: Yes

Important parts:

driver: modesetting,nvidia
unloaded: fbdev,nouveau,vesa
OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2 v: 4.6.0 NVIDIA 415.27 
  direct render: Yes

I have this output

System:
  Host: tom-dell Kernel: 4.20.0-042000-generic x86_64 bits: 64 compiler: gcc 
  v: 8.2.0 Desktop: Gnome 3.30.1 wm: gnome-shell dm: GDM3 
  Distro: Ubuntu 18.10 (Cosmic Cuttlefish) 
Machine:
  Type: Laptop System: Dell product: XPS 15 9570 v: N/A 
  serial: <root required> Chassis: type: 10 serial: <root required> 
  Mobo: Dell model: 0D0T05 v: A00 serial: <root required> UEFI: Dell 
  v: 1.7.0 date: 12/25/2018 
Graphics:
  Device-1: Intel driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: nvidia 
  v: 415.27 bus ID: 01:00.0 chip ID: 10de:1c8c 
  Display: wayland server: X.Org 1.20.1 driver: modesetting,nvidia 
  unloaded: fbdev,nouveau,vesa compositor: gnome-shell 
  resolution: 2880x1620~60Hz, 3840x2160~60Hz 
[u][b]  OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) 
  v: 4.5 Mesa 18.2.2 compat-v: 3.0 direct render: Yes[/b][/u]

First things first: Don’t use Wayland , use X.

Second: You’re still on Intel as we can see at renderer line.

Third: Open terminal and do this:

sudo prime-select nvidia

See if this will work or not.

already did.

Info: the nvidia profile is already set

Please make sure you disabled wayland:
https://askubuntu.com/questions/975094/how-to-disable-wayland-in-17-10-in-gdm3-login-screen
If that doesn’t help, check if the file /lib/modprobe.d/nvidia-kms.conf exists and change
modeset=1 to modeset=0
and run sudo update-initramfs -u

I disabled it and now the boot loading stop on the Ubuntu loading before the logging

Any solution?

Check if using lightdm instead of gdm helps:
https://askubuntu.com/questions/139491/how-to-change-from-gdm-to-lightdm

I followed the installation and selected gdm3, but nothing seems changes

I’m not sure what exactly you did now, you should have done

sorry for the attendance. I attached the file in the original post

I also got that problem. Anyone help me.

A simple resintall of nvidia drivers fixed my issue
sudo apt-get install --reinstall nvidia-driver-440