Ubuntu 18.04 seems not to apply drivers at startup

I’m running Ubuntu 18.04, and whenever the PC starts it’s like the drivers aren’t properly run, lines on for instance on Facebook and Nvidia Developer all lines (borders, hr(HTML), bgcolors etc) are gone. Once i start the nvidia x-server settings program, then the drivers are instantly applied and i can quit it again.

This issue also occurs when the PCs been running for a couple of hours, like when i went back to write this ticket.
Seen on latest Firefox, i’ll check on chrome next time the issue appears.


A solution to this would be lovely :-)

I’m a little confused by your reported symptoms. Is the issue that colors on the screen are displayed incorrectly until you start nvidia-settings?

Based on those symptoms, it sounds as if your desktop environment is loading a strange color profile and nvidia-settings is overriding it when it loads. As an experiment, can you please try running xrandr --output DVI-D-0 --brightness 1 to see if it fixes the problem?

Use xrandr without any arguments to find out the name of your primary output device.

Also, this command doesn’t need to be run under sudo. In fact in most cases it will fail.

Thanks for your answer.
It’s hard to say what goes wrong, maybe incorrect parsing of CSS, bgcolor of tables/dvis are gone until the nvidia-settings are started.
I guess the statusbar on this page with created, last reply etc will miss the grey backgroud and the border aswell, i’ll make screendumps next time.
I’ll test the xrandr command next time too, thanks.
Kind regards

Now it’s getting wierd, cause border and grey background where gone when i took the screenshot, and still missing afterwards, but not in the screenshot itself?

I tried xrandr, didn’t make a difference.

After opening nvidia-settings i saw 3 lines in syslog:
Mar 18 13:55:04 test050 nvidia-settings[13243]: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
Mar 18 13:55:04 test050 nvidia-settings[13243]: PRIME: No offloading required. Abort
Mar 18 13:55:04 test050 nvidia-settings[13243]: PRIME: is it supported? no

After starting nvidia-settings it displays border and background correct again (aaaand i’m only allowed to upload one image as new user…?) screenshot after

It’s the same in Chrome, so not a browser issue.

Kind regards.

A set of 390 packages was still installed, i removed them and i altered /etc/default/grub, removed “quiet splash” from GRUB_CMDLINE_LINUX_DEFAULT and added nvidia-drm.modeset=1, now it’s constant that (some) background colors are not shown, for instance in Facebook messenger, my own words are in blue background, but the other persons chatlines are white (no) background, instead of grey.

These are the packages currently installed, am i missing some?
dpkg --get-selections | grep nvidia
libnvidia-cfg1-440:amd64 install
libnvidia-common-440 install
libnvidia-compute-390:amd64 deinstall
libnvidia-compute-390:i386 deinstall
libnvidia-compute-430:amd64 deinstall
libnvidia-compute-440:amd64 install
libnvidia-compute-440:i386 install
libnvidia-decode-440:amd64 install
libnvidia-decode-440:i386 install
libnvidia-encode-440:amd64 install
libnvidia-encode-440:i386 install
libnvidia-fbc1-440:amd64 install
libnvidia-fbc1-440:i386 install
libnvidia-gl-440:amd64 install
libnvidia-gl-440:i386 install
libnvidia-ifr1-440:amd64 install
libnvidia-ifr1-440:i386 install
nvidia-compute-utils-440 install
nvidia-dkms-440 install
nvidia-driver-430 install
nvidia-driver-440 install
nvidia-kernel-common-440 install
nvidia-kernel-source-440 install
nvidia-prime install
nvidia-settings install
nvidia-utils-440 install
xserver-xorg-video-nvidia-440 install

sorry, didn’t get back to you on that. This is the output:

xyz@myUbuntu:~$ xrandr
Screen 0: minimum 8 x 8, current 3600 x 1080, maximum 16384 x 16384
VGA-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 459mm x 296mm
1680x1050 59.88*+ 59.95
1280x1024 75.02 60.02
1280x960 60.00
1152x864 75.00
1024x768 75.03 70.07 60.00
800x600 75.00 72.19 60.32 56.25
640x480 75.00 72.81 59.94
HDMI-0 connected primary 1920x1080+1680+0 (normal left inverted right x axis y axis) 598mm x 336mm
1920x1080 60.00*+ 59.94 50.00
1680x1050 59.95
1600x900 60.00
1440x900 59.89
1280x1024 60.02
1280x800 59.81
1280x720 60.00 59.94 50.00
1024x768 70.07 60.00
800x600 72.19 60.32 56.25
720x576 50.00
720x480 59.94
640x480 59.94

Could it be something with the processes says “Not supported”? I’ve tried with both gdm3 and ligthdm.

root@test050:~# nvidia-smi
Wed Mar 25 15:55:19 2020
| NVIDIA-SMI 440.64 Driver Version: 440.64 CUDA Version: 10.2 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| 0 GeForce GT 710 Off | 00000000:01:00.0 N/A | N/A |
| N/A 58C P0 N/A / N/A | 332MiB / 1998MiB | N/A Default |

| Processes: GPU Memory |
| GPU PID Type Process name Usage |
| 0 Not Supported |

Do you have a converter/kvm switch between gpu and monitor? This really sounds like some color profile issue, Gnome’s color-manager getting confused, loading an incorrect profile. You can check the loaded one in Gnome’s control center. IIRC, starting nvidia-settings resets the color profile.

I have two monitors connected to the PC, one (Samsung Syncmaster) is connected to a KVM, and I’ve just discovered that it works on the Syncmaster, but only the other monitor (Samsung Curved C27F591), connected to the HDMI port has the problem. If i move the affected browser to the syncmaster bgcolors are shown. Maybe a monitor issue? I’ll look into that now.
Here’s my xorg.conf:

nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 440.64

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”

Section “Files”

Section “Module”
Load “dbe”
Load “extmod”
Load “type1”
Load “freetype”
Load “glx”

Section “InputDevice”

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"


Section “InputDevice”

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"


Section “Monitor”

# HorizSync source: edid, VertRefresh source: edid
Identifier     "Monitor0"
VendorName     "Unknown"
ModelName      "Samsung SyncMaster"
HorizSync       30.0 - 81.0
VertRefresh     56.0 - 75.0
Option         "DPMS"


Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce GT 710”

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
Option “Stereo” “0”
Option “nvidiaXineramaInfoOrder” “DFP-1”
Option “metamodes” “DVI-D-0: nvidia-auto-select +0+0, HDMI-0: nvidia-auto-select +1680+0”
Option “SLI” “Off”
Option “MultiGPU” “Off”
Option “BaseMosaic” “off”
SubSection “Display”
Depth 24

Like said, rather a wrong color profile. Please check Gnome’s control center for it.

Now that i understand the command a bit better xrandr --output HDMI-0 --brightness 2 will change brigtness on the affected monitor. xrandr --output HDMI-0 --brightness 1 to set it back. But the bgcolor is still not shown. From what i’ve read it could relate to an HDMI issue once nvidia modeset is set to 1 and i did try to change /etc/default/grub GRUB_CMDLINE_LINUX_DEFAULT=“nvidia-drm.modeset=1” (and update-grub, then reboot), and i believe it was after this i permanently got the missing bgcolors. Starting nvidia-settings wont do a difference no more.
If i do cat /sys/module/nvidia_drm/parameters/modeset returns ‘N’, i would expect Y
I also tried GRUB_CMDLINE_LINUX_DEFAULT=“nvidia-drm.modeset=0”, update-grub and reboot, still the same issue with the HDMI.

It’s using “automatic - C27F591”, i’ve added a “Test profile - Swapped Red and Green”, with no difference. Do you recommend a specific profile?

Found a cure. In nvidia-settings, i’ve changed the brigtness to -0.20 - It’s not the optimal solution, since it affects colors on this monitor (for instance default color of terminal is purple, but it’s nearly black now), so a better solution would be fine. But it works for now.

YES! Found it. The Samsung C27F591 had a mode in the picture menu called “HDMI Black Level”, this was set to Low. Changing this to Normal gave the result i expect.

I do find it strange that it at my first post worked if i started the nvidia-settings, this program can’t manipulate the monitor can it? I’ve never messed with this setting my self.

Anyway, thanks for your help, both the xrandr tip and the color profile tip led me in the right direction :-)

Kind regards

Ok, it was the HDMI color range setting then. Is either ‘full’ or ‘limited’. Monitor and gpu have to have the same setting, it should be automatically detected but sometimes (like in your case) this doesn’t work.
Setting your monitor to ‘full’ aka ‘normal’ is the better setting anyway.

1 Like