Ubuntu 22.04 black screen AFTER log in (upgraded from 20.04)

  • I posted this as a comment on another thread but I got no replies and I think my issue is different than those described in the thread.

Hello, I upgraded from Ubuntu 20.04 to 22.04 and I cannot get the GUI to work past the login screen.

I tried several things I read in this thread but nothing worked for me. Over the past week I did several tests, also with the help with Canonical support without being able to find a solution yet.

Behavior:
The system boots normally and reaches Ubuntu log-in screen. Here the resolution looks as if the driver loaded fine since the minimal graphics is displayed in the monitor’s native display resolution, 4K, without looking enlarged or pixelated as when the drivers do not load. The anomaly here is that the background has no graphics and is fully grey. If I log in, the screen goes black. I can access the command line with ctrl alt f5.

Some of the tests I did:

  • Upgrade from the latest generic kernel to OEM. No difference so I went back to generic.
  • Changed drivers multiple times. I tried different Nvidia drivers both supplied by the distro and from third-party ppa. No difference so I went back to the latest 5.20 available on ppa.
  • Purged Nvidia drivers and tried Nouveau. Same behavior. Went back to Nvidia and re-blacklisted Nouveau.
  • Deleted and re-generated xorg.conf - no difference
  • changed options nvidia-drm modeset=1 to options nvidia-drm modeset=0 - no difference

Drivers appear to load.

One anomaly I noticed is that lshw does not show the card model. It only says generic Nvidia VGA device or something along those lines.

My card is a 3090Ti.

If I go back to 20.04 via backup, everything works fine. I re-upgrade and the problem comes back.

If I boot Ubuntu from live USB, GUI works after login. However, I get some color artifacts probably because of the Nouveau drivers that come with it.

Any help would be very apperciated.

Nvidia logs are attached.

Thanks.

nvidia-bug-report.log (3.2 MB)

1 Like

Maybe related to this Try using kernel version 5-15-0-48 or before.

The driver is working fine, the Xserver is running but there doesn’t seem to be any gnome-shell session starting. Please check journalctl for any messages regarding it.

Thanks. I ran journalctl -p err -b to to look for errors and a lot of stuff came out. I’m attaching some screenshots. Thank you.





I guess you should rather look for gnome-shell messages and put it in a file
sudo journalctl -b0 |grep gnome-shell >journal.txt

Here is the file. Thank you.

journal.txt (7.7 KB)

gnome shell is properly starting for the gdm session but not even tried to be started for the user.
Can you actively choose a session from the gdm cogwheel menu and then log in?

GDM cogwheel does not display on login page. Probably because Wayland is disabled in conf so there is only X11 active and the cogwheel is not necessary?