Ubuntu 22.04: HDMI not working on Razer Blade Advanced 15 (2021) RZ09-0367BEC3

My HDMI port on the Razer Blade Advanced 15 has not worked since I installed Ubuntu 20.04 (when I bought it in June 2021). I’ve not needed the HDMI port until now, so I thought I would upgrade to Ubuntu 22.04 and maybe it would fix it…it didn’t.

Per many support threads out there, it appears to be related to my NVIDIA driver.

When I use:

$ sudo nvidia-settings

I get the following:

ERROR: NVIDIA driver is not loaded

I have tried the following commands with no success:

$ sudo prime-select intel
$ reboot

$ sudo prime-select nvidia
$ reboot

Here’s what I am using:

  • Ubuntu 22.04
  • 5.13.12-051312-generic
  • GeForce RTX 3070 Mobile/Max-Q
  • NVIDIA driver metapackage from nvidia-driver-515 (via Software & Updates: Additional Drivers)
  • Secure Boot disabled in BIOS

Any help would be appreciated.

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

I ran the bug report:

$ sudo bash nvidia-bug-report.sh

nvidia-bug-report.log.gz (96.5 KB)

You’re currently running a non-standard kernel without the nvidia driver installed. An earlier boot with the nvidia driver resulted in
NVRM: GPU 0000:01:00.0: RmInitAdapter failed! (0x22:0x56:731)
which would point to defective hardware.
Please boot to the standard 5.15 kernel and check if it reproduces.

I had the same issue in 5.15 kernel. I don’t have that kernel installed right now as I started trying earlier versions of kernels to attempt to get it working (with no avail). I’ll go ahead and install 5.15 again and test / rerun nvidia-bug-report.sh as root. I’ll post here again later this evening.

I installed kernel 5.15.63-051563-generic and the problem persists.

Here’s the new bug report:

$ sudo bash nvidia-bug-report.sh

nvidia-bug-report.log.gz (101.3 KB)

Scratch that. I had to update to 5.18.19-051819-generic as my WIFI would not work properly on 5.15.63-051563-generic. Unfortunately, still having same HDMI problem.

Here’s the new bug report:

$ sudo bash nvidia-bug-report.sh

nvidia-bug-report.log.gz (97.7 KB)

You can’t just wildly install any kernel images, the headers have to be compatible so the nvidia driver can be compiled. Please use the liquorix ppa to get a new kernel and a working nvidia driver.

Ok, I have add the liquorix ppa:

https://ppa.launchpadcontent.net/damentz/liquorix/ubuntu/ (main) 

and am now runnng on kernel 5.19.0-4.1-liquorix-amd64.

I have the NVIDIA ppa:

https://ppa.launchpadcontent.net/graphics-drivers/ppa/ubuntu/ (main)

Software & Updates > Additional drivers, I have selected the NVIDIA driver metapackage from nvidia-driver-515 (proprietary, tested).

Here what I get when I run:

$ sudo nvidia-settings

ERROR: A supplied argument is invalid

(nvidia-settings:5644): GLib-GObject-CRITICAL **: 22:18:27.397: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

** (nvidia-settings:5644): CRITICAL **: 22:18:27.399: ctk_powermode_new: assertion '(ctrl_target != NULL) && (ctrl_target->h != NULL)' failed

ERROR: nvidia-settings could not find the registry key file or the X server is
       not accessible. This file should have been installed along with this
       driver at
       /usr/share/nvidia/nvidia-application-profiles-key-documentation. The
       application profiles will continue to work, but values cannot be
       prepopulated or validated, and will not be listed in the help text.
       Please see the README for possible values and descriptions.

** Message: 22:18:27.441: PRIME: Requires offloading
** Message: 22:18:27.441: PRIME: is it supported? yes
** Message: 22:18:27.479: PRIME: Usage: /usr/bin/prime-select nvidia|intel|on-demand|query
** Message: 22:18:27.479: PRIME: on-demand mode: "1"
** Message: 22:18:27.479: PRIME: is "on-demand" mode supported? yes

In the NVIDIA settings popup, under PRIME Profiles, I have selected: “NVIDIA (Performance Mode)”

After this, I ran these commands but it didn’t change any of the NVIDIA Settings messages above:

$ sudo prime-select nvidia
$ reboot

Here’s my bug report:

$ sudo bash nvidia-bug-report.sh

nvidia-bug-report.log.gz (125.5 KB)

The nvidia gpu fails to initialize:

[   15.290819] ACPI BIOS Error (bug): AE_AML_BUFFER_LIMIT, Field [TMPB] at bit offset/length 1572864/32768 exceeds size of target Buffer (262144 bits) (20220331/dsopcode-198)
[   15.290825] ACPI Error: Aborting method \_SB.PCI0.PEG0.PEGP._ROM due to previous error (AE_AML_BUFFER_LIMIT) (20220331/psparse-529)
[   15.290849] NVRM: GPU 0000:01:00.0: Failed to copy vbios to system memory.
[   15.290956] NVRM: GPU 0000:01:00.0: RmInitAdapter failed! (0x30:0xffff:948)
[   15.291011] NVRM: GPU 0000:01:00.0: rm_init_adapter failed, device minor number 0

at the same time, the TB controller and other devices are freaking out

[   15.304432] pcieport 0000:00:1d.4: AER: Corrected error received: 0000:05:00.0
[   15.304444] pcieport 0000:05:00.0: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Receiver ID)
...
[   44.065947] thunderbolt 0000:07:00.0: AER: can't recover (no error_detected callback)
[   44.065948] xhci_hcd 0000:09:00.0: AER: can't recover (no error_detected callback)
[   45.299178] pcieport 0000:00:1d.4: DPC: Data Link Layer Link Active not set in 1000 msec

Please check for a bios update.

I found this thread discussing issues with external monitor due to bios issue.

Razer released BIOS 1.09 which fixes the issue of not having DisplayPort out over the dGPU using the Thunderbolt 4 USB-C ports. External monitors only worked through the iGPU and framerates took a hit.

Unfortunately, I can’t seem to find the bios for this laptop without using their BIOS Updater which is only Windows compatible.

NOTE: I went into the bios to see if there was an option to check for updates, and there was not one. I will have to find the new version of the bios online and manually flash the bios.

Just posting this here as others may find this helpful later. I’ll keep looking.

Found the same. Trying to dig deeper, it seems Razer doesn’t release firmware images and only allows updating through their Windows-only “BIOS Updater” application.
So you’ll either have to install windows or create a windows pe usb boot stick.
https://superuser.com/questions/1518167/create-a-bootable-usb-of-windows-pe-on-linux

I’m allergic to Windows, so I will go with the Windows PE bootable USB stick. :)

Ok, I created a boot thumb drive (Hiren’s BootCD PE x64 (v1.0.2)) and was able to boot into Windows PE successfully. I downloaded the latest Razer Blad Bios Updater and placed it on a USB drive and ran it. I got a device error when running the bios updater file. The error looks related to a driver issue.

I noticed that my wifi didn’t work and so I imagine that this version of Windows will not work well with this Razer. I’m going to create another boot disk of a different version of Windows and try again.

Does the notebook have an ethernet port? Maybe those drivers are included in the WinPE image.

The laptop doesn’t have an ethernet port, which is fine. My access to the internet is not the issue. I’m going to load a Windows ISO that is newer and hopefully it can run this Bios Updater exe file.