Ubuntu Cuda 3.1 Download not found

I’m trying to install CUDA 3.1 Toolkit on a new system but the download gives a not found error every time. I’ve tried to access it via 3 different computers from 3 different countries using wget, firefox, and lynx to try and download it, all to no avail so I’m beginning to believe it really might not be there. Anyone else had any problems with the download? Could someone else try this as well? It seems weird to post this in a forum, I feel I should be calling a customer support line, I hope it gets back to the right people. Who should I talk to about problems like this?
I’m trying to get the 64 bit ubuntu version of the toolkit:
http://developer.download.nvidia.com/compu…_ubuntu9.04.run
from the nvidia download site: http://developer.nvidia.com/object/cuda_3_1_downloads.html
I find the ubuntu 32 bit version is also missing, I tried a handful of the downloads for the other distros and they all worked, just ubuntu is missing.
Thanks
Scott

I have the same problem…

LINK BROKEN FOR UBUNTU

Visibly, they don’t keep the outage version 9.4 of Ubuntu to give a 9.10 version.

http://developer.download.nvidia.com/compu…_ubuntu9.10.run

Cheers

OMG i just formatted my pc and installed 9.04

Link on the site is indeed broken, the 9.10 link by numa works