Ubuntu Internal error when selecting desktop sharing in settings.

@kylemcdonald Thank you so much for pointing this out.

I’m sorry for incorrect posting.

I have fixed two missspelled.

gsettings set org.gnome.vino prompt-enabled false
gsettings set org.gnome.vino require-encryption false

Thanks.

Hi, @nekokeitai
I got the same error:

lbl@lbl-jetson-nano:~$ gsettings set org.gnome.vino prompt-enabled false
No such schema “org.gnome.vino”

Note that the command is case sensitive, use gsettings set org.gnome.Vino prompt-enabled false

The ‘V’ from Vino should be capitalized.

I have fixed again.
“org.gnome.Vino” and added “export DISPLAY=:0”.

Thanks a lot

Thanks for help.

But I still can not lauch vino server. I am using a newly installed system based on the image “jetson-nano-sd-r32.1-2019-03-18.zip”.

lbl@lbl-jetson-nano:~$ nmcli connection show
NAME                UUID                                  TYPE      DEVICE
Wired connection 1  0bed475c-0fbf-3610-87ea-a413bcd8fd4a  ethernet  eth0
l4tbr0              d261db64-efbf-4da7-8b45-868beaebdfd5  bridge    l4tbr0
lbl@lbl-jetson-nano:~$ dconf write /org/gnome/settings-daemon/plugins/sharing/vino-server/enabled-connections "['0bed475c-0fbf-3610-87ea-a413bcd8fd4a']"
lbl@lbl-jetson-nano:~$ export DISPLAY=:0
lbl@lbl-jetson-nano:~$ /usr/lib/vino/vino-server
No protocol specified
Unable to init server: Could not connect: Connection refused
Cannot open display:
Run 'vino-server --help' to see a full list of available command line options

Hi,

I think this whole discussion got derailed because the op wanted to use “VNC in headless mode without a monitor”.

@franticupl4e: You are not supposed to start vino-server from the command line. The desktop (e.g. GNOME Shell) has to manage the start of vino-server. That is why we were discussing different paths to get the VNC server working. I am sorry to say this, but the “accepted answer” by nekokeitai is not the right way to approach the problem.

In the meantime I have decided to remove Unity (no reason to keep it), deactivate GDM and respectively GNOME Shell, and to install Xfce and LightDM. This dramatically reduces memory consumption (~1.200 MB with GNOME Shell vs ~800 MB with Xfce) and allows the desktop to actually start in headless mode (although there are still problems with hardware acceleration). If you are interested I can write a step-by-step guide.

Hi, @klicker100

Thanks for pointing that out.

Actually, I was managed to setup a remote desktop via vnc4server + xfce solution at the very beginning. But the webcam streaming was not working, the same as the video playing. The only scenario I would use a remote desktop is testing the inference in a video. So I still need to find other solution. Have you face the same problem? Do you know how to fix it?

Found this article https://blog.hackster.io/getting-started-with-the-nvidia-jetson-nano-developer-kit-43aa7c298797 while googling: Jetson Nano “headless”

Look down in [Enabling Desktop Sharing] section. The first thing you need to do is to edit the org.gnome.Vino schema to restore the missing enabled parameter.

$ sudo vi /usr/share/glib-2.0/schemas/org.gnome.Vino.gschema.xml

and go ahead and add the following key into the XML file.

<key name=’enabled’ type=’b’>
   <summary>Enable remote access to the desktop</summary>
   <description>
   If true, allows remote access to the desktop via the RFB
   protocol. Users on remote machines may then connect to the
   desktop using a VNC viewer.
   </description>
   <default>false</default>
</key>

Then compile the Gnome schemas with the glib-compile-schemas command.

$ sudo glib-compile-schemas /usr/share/glib-2.0/schemas

This quick hack should stop the “Desktop Sharing” panel crashing, allowing you to open it. So go ahead and click on the “Settings” icon, and then the “Desktop Sharing” icon…

A much better solution is to install ‘xrdp’ as suggested in [Enabling Remote Desktop] section, as that can really make your Nano purely headless and also allow occasional attaching a monitor.

1 Like

Thank you so much #18!! that worked out!!

Hi I am a total newbie at Ubuntu and I would really appreciate some help. I have typed in this

$ sudo vi /usr/share/glib-2.0/schemas/org.gnome.Vino.gschema.xml

but I cannot seem to edit the code to add in the ‘enabled’ key. How do I do that? Love to hear from you guys. Thank you!

I would like an alternative to vino as it’s not feasible to attach a monitor to my nano, so I need a headless virtual desktop.

I tried this:

sudo apt install tigervnc-standalone-server tigervnc-xorg-extension -y

…but apt found no such packages.

Elsewhere there’s a blog that says I could also install xrdp:

https://www.hackster.io/news/getting-started-with-the-nvidia-jetson-nano-developer-kit-43aa7c298797

…but I get the same message (not found).

Is a repository where I can retrieve either of these?

Hello xtz465,

You might need to add the Universe repository first:

sudo apt-add-repository universe
sudo apt update

and then try running your tigervnc options again.

Good luck,

IceBlackz

I get this:

% sudo apt-add-repository universe
‘universe’ distribution component is already enabled for all sources.

…and this:

% sudo apt update

part of long output:

Err:19 http://ports.ubuntu.com/ubuntu-ports bionic-updates Release
Cannot initiate the connection to ports.ubuntu.com:80 (2001:67c:1360:8001::22). - connect (101: Network is unreachable)
Err:20 http://international.download.nvidia.com/jetson/repos/t210 r32 Release
Cannot initiate the connection to international.download.nvidia.com:80 (2606:2800:21f:3aa:dcf:37b:1ed6:1fb). - connect (101: Network is unreachable)
Err:21 http://ports.ubuntu.com/ubuntu-ports bionic-backports Release
Cannot initiate the connection to ports.ubuntu.com:80 (2001:67c:1360:8001::22). - connect (101: Network is unreachable)
Err:22 http://ports.ubuntu.com/ubuntu-ports bionic-security Release
Cannot initiate the connection to ports.ubuntu.com:80 (2001:67c:1360:8001::22). - connect (101: Network is unreachable)

Is this a problem? Not sure what to do about it.

That looks like you might have some issues with your network, are you behind a proxy or perhaps your DNS isn’t configured correctly? It seems to resolve to an IPv6 address, perhaps that can also influence your results

I’ve been running an ad blocker through a Raspberry Pi for half a year or so. I don’t encounter many blocked sites that I actually need, and in any event there’s a whitelist for exceptions. I added ports.ubuntu.com to that list, but apt stilll doesn’t connect, even though I can navigate to that site in a browser.

In any event I reconfigured the router to bypass the ad blocker, and I’m getting the same (non) results.

I also have 4 Raspberry Pis running stretch and an Odroid N2 running Ubuntu, and I’ve never encountered this problem (apt update) with any update with them through the ad blocker.

addendum:

I can ping ports.ubuntu.com successfully from the Odroid N2 running Ubuntu 18.04.

If ping ports.ubuntu.com from the nano, I get “destination host unreachable”

So there is clearly a setting on the nano that has to be changed.

I tried editing /etc/sysctl.conf and then

sudo sysctl -p and then

cat /proc/sys/net/ipv6/conf/all/disable_ipv6
1

Still no success.

addendum[2]:

I fixed the “host unreachable” problem. The config file had a bad gateway address.

No I have run

sudo apt update

successfully…

but there is still no sign of xrdp or tiger vnc.

[SOLVED]

Somehow tiger vnc showed up, and it’s now installed and running a virtual desktop.

hii @Rtc

when i add this key in XML file it shows

“Error on line 158 char 17:odd character ‘&’, expected an quote mark after equals sign when giving valve for attribute ‘name’ of element ‘key’. this entire file has ignored”

please help

On my installation, ‘’‘nmcli connection show’’’ keys for my Ethernet and WiFi connections list. However, /org/gnome/settings-daemon/plugins/sharing/ has no /vino-server/enabled directory. Is there a way to use the Gui to add the Name UUID data?