About Vino

Hello,


After completing the vino settings for remote connection, I connected to the jetson nano with a vnc client and used it well.
After rebooting, vnc connection is not working.
As you can see, vnc is floating.

How to fix it?

Thank you.

If you configure the setting again, will it able to work again?

restart?

Hello,

I follow this article.

Thank you.

Hello,

Currently, Nano is in a remote location (L.A., USA), and the employees are now leaving work.
So, I cannot set the Desktop Sharing screen on the GUI screen.

Is there a way to set it up manually?

Thank you.

I don’t think you need to use the GUI to set up this.

  1. export DISPLAY=:0
  2. gsettings set org.gnome.Vino enabled true
  3. gsettings set org.gnome.Vino prompt-enabled false
  4. gsettings set org.gnome.Vino require-encryption false
  5. /usr/lib/vino/vino-server
  6. Tried vnc client.
1 Like

Hello,

export DISPLAY=:0

gsettings set org.gnome.Vino enabled true

gsettings set org.gnome.Vino prompt-enabled false

gsettings set org.gnome.Vino require-encryption false

/usr/lib/vino/vino-server

No protocol specified

Unable to init server: Could not connect: Connection refused

Cannot open display:

Run ‘vino-server --help’ to see a full list of available command line options

Thank you.

Hello,

You can set a password on the GUI screen.
Can’t I set a password from the command line?

Thank you.

Hello,


I connected to a Windows PC in LA as a team viewer in Seoul, and I connected to two jetson nano units using a vnc client on that window pc (using vino).

But the resolution is different
I can’t properly control the nano indicated by the green arrow on the right
How can I solve this problem?

Thank you.

Do you have a physical monitor connected there?

1 Like

yes

What is the mode supported by that monitor?

1 Like

Hello,

It is difficult to check because the team viewer connection is not available now.
I will inform you tomorrow at around 8 am (Korean time).

Thank you.

you can just type “xrandr” and it will tell you the modes…

Hello,

jetson nano is in LA.
The current employees are out of work.
I will leave a comment if I check it tomorrow morning.

Thank you.

Hello,

The result of xrandr is:

xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 160mm x 90mm
1920x1080 60.00*+ 59.95 50.00 30.00 29.97 24.00 23.98
1280x720 60.00 59.94 50.00
1024x768 60.01
800x600 60.32
720x576 50.00
720x480 59.94
640x480 59.94 59.94
DP-0 disconnected (normal left inverted right x axis y axis)

Thank you.

Your monitor is already in 1080p. I don’t get why “xrandr -s” said there is not such size. Please check it on your side.

1 Like